Guide: How to top-up an existing neuron

@hpeebles , thanks for this thread. I tried the increase neuron stake using the new button, and it didn’t update the amount of ICP displayed in the neuron on nns, despite waiting a couple days. Could you please help me with this? This is the transaction hash: 83045b3c4504685aba368a0a0cc49e76c423c359c195c6b557d861f13e97bb92

I think it didn’t update because the neuron that I increased the stake on was created 6/15 (before 6/19). The neuron # is 5693716811461854478 and principal ID is n6yy2-j5has-dbypr-bce5j-6zql3-4zcem-dlcbq-c6suv-by7wn-hy46n-yae

Thanks again!

I know that support for managing seed neurons via dfx is being worked on. I’ve just asked when this functionality will be available. Once I know more I’ll post an update here.

Did you end up getting a response on this eta to support managing seed neurons via dfx?

Ah I see what has happened. This neuron was created via disbursing an existing neuron.

Neurons created this way (+ seed neurons) can’t currently be refreshed using the same method as neurons created through the usual process.

Support for this is coming soon but the person implementing it is away for another week so I can’t give an accurate estimate. I’ll post in here once I know more though.

@aaa10247 this is the timeline you’re after too.

can you help me enter my icp in my old NNS account? I used a new NNS account because I failed to login in various ways, none of them worked, so I couldn’t buy a yubikey, and I replied to an email to the ICP guide with Robert Bodily also it seems he doesn’t can you help me, my old account’s NNS wallet address is still there, can I check on my binance account, to enter my old NNS account balance into my new NNS account, thanks in advance

Hi, I just increased my stake about 2 hours ago and the amount of ICP in the Neurons is not updated. Likely mine is one of the older neurones and require manual updating.

My Principle ID is hykyc-6qs3t-bar3y-7dbob-pimxp-4rjny-cn35i-5vhyr-e4ebj-de4m7-oae

Memo is 1230289953267954234

Also, do I still have to approach you for manual updating should I increase my stake again in future?

The above transaction was done using seed neurons.

@Bapakeanak2 the only possible way to access that ICP is to gain access to the account which owns the ICP.
It is probably worth firing a request over to the support team and explaining why you can no longer log in.
They may be able to to help you out.

@MiniWinks support for seed neurons is coming in the next few weeks. Until that time there is nothing that we can do. But don’t worry your tokens are still safe! And once the seed neuron support is live we will be able to refresh the balance of the neuron.

Thanks, @hpeebles.
I’m more reassured now. Until ICP solves the problem, will the neuron continue accrue maturity (aka rewards)? There is a matter of opportunity costs here.

Also, can you drop me a message when support does arrive? Thanks!

I’m curious why my neurons stopped maturing recently. All three stopped 3 days ago and there’s been lots of voting going on. They’re all staked for more than a year and had been maturing daily untill recently.

Hi, Would you know a way to top up a neuron via command line, not the nns? For example, I spawn a neuron, dissolve it, and then I’d like to add to ICP to the original neuron?

It’s not possible to do that currently

Any news on the time for this feature to be released?

1 Like

Hi @hpeebles I am wondering if you can help me with a problem please? I have topped up a neuron today and it was on the loading screen for a long time. I refreshed the page and it shows the ICP has been sent to the neuron but it is not appearing in my neuron. I sent the ICP to 91ca4e3cf81b9f7c7f85f489b403981895b79cf4e68ee7b1cc5a8de39b8401e5

Principal id is “a4n7b-blydr-uefpu-dgcmr-dk55c-uzcpo-yyryk-c4fac-x7t32-5fuiu-oae”
Memo is “5192537560665806211”

Thank you in advance for any help you can offer me with this. Thank you

Hi hpeebles, any updates on the support mentioned? It’s been 3 weeks and I’m still unable to see the additional neurons.

I’ve just been chasing about this and have been told that we are aiming to get the fix out to production tomorrow.

The NNS Dapp will be adjusted to use this new method for refreshing neurons in a few days time but for now I will do it manually.

I’ll post in here once I’ve refreshed each of your neurons :+1:

1 Like

Hi, do you mean the seed neuron staking will be fixed? Hope so, I’ve had loads of ICP stuck there for the past month.

Hi Peebles,
Can you help me update my neuron?
I happened to send ICP coins to one of my rewards neuron. The transaction is complete and can be checked on, but the number of ICP has not been updated on neuron.
My principal id is “k65rb-egsdz-p7pcy-hjayc-t7a5e-tmxk4-7iuld-m6npb-yvyvn-42som-gae”
Address: 496280755203415deba2940cebbb81a0fc4bed2f9531b985ae55fb48122b526a
Thanks a lot to help me update neuron manually.
Best regards

Hello hpeebles,
i really hope you can help me. Im a student and invested a in ICP.
Just could skate my fist neuron and sent it to main wallet. There i got another 18 Coins i wantet to stake. Also i toped up and then an error arised. I loged out and in and could see it choosed the same adress i recived my neuron. Now i cant see my 19 icp-coins anywhere. Thats really alot money for me and i hope you can help me out or know what i could do?

I think its the same problem swedishlalala had.
My principal id is:
Neurons: Your principal id is “yj7kg-kavee-u22ud-pcowi-cyea5-fcufj-mmmcb-re6ta-ymhw7-x33uq-dqe”
Its sent to the recived Neurons adress “2a309510c1f81504d2d0bcb0b0c44506f9e72e97973d058537fae510cafc7932”
and should go to
i really hope you can help me out. you would be my heroe. Thanks for helping.

Yes! Once the change that is going through review has gone out to production all neurons will be able to be refreshed.

@Swedishlalala I can see you sent the ICP to a newly spawned neuron’s address. We can’t currently refresh balances for newly spawned neurons but your ICP is safe and we will be able to refresh the balance shortly.

@HiPZzTR_1 you’re right its the same issue and will be fixed soon. Your ICP is completely safe so don’t worry!