Unable to disburse spawned neuron

I seem to be unable to disburse spawned neurons, as of yesterday afternoon. (The activity indicator just keeps spinning, and doesn’t resolve.) Is this a known issue?

In case it’s helpful, I’ve tried to disburse the spawned neuron to both my main ICP account and also to another neuron (topping up). I’ve tried using Chrome on my MacBook Air and Safari on iPhone.

1 Like

I’m having a similar issue - clicking “Spawn Neuron” and then “Yes, I’m sure” results in the page never progressing past the spinning activity indicator.

1 Like

Steps to reproduce, on my end:

  1. Enter spawned neuron whose 7-day dissolve delay has fallen to 0.
  2. Click “Disburse.”
  3. Enter address (neuron to top up, or ICP address), and click “Continue.”
  4. Click “Confirm and Send.”

Activity indicator spins without resolving.

Same issue. Cannot spawn neuron. Activity indicator spins without resolving.

Thank you for letting us know. I have passed this to the engineering team to investigate. Fwiw, one of our engineers was able to reproduce on their end as well.

Well update as we learn more…

2 Likes

Yep, exactly same for me. I will follow development on this thread.

I have the same problem, I just staked some ICP, but I didn’t set any dissolve delay. Now I can not disburse and the transaction remains unfinished.

Update of a non-update: we are still looking into this.

I thought folks may appreciate if I should acknowledge that rather than silence even if engineers are heads down.

4 Likes

We are investigating the issue and are fairly certain we’ve pinpointed the cause. We are working to get a fix out as soon as we can.

The only affect this is having is that some ‘manage neuron’ commands are failing, eg. ‘Disburse’, ‘Spawn’, etc.

You can follow the status page for updates - InternetComputer Status - Failures in NNS DApp

2 Likes

Fix is now live!

Let me know if you still have any issues

5 Likes

It works! Thanks for the fix!

Can we know what was the issue? And will this likely happen again?

Works great!
Any update on the other issue for updating neurons and maturity created from a Spawned neuron?

The NNS Dapp version that was released yesterday was using governance canister functionality that hadn’t been released yet.

The governance canister is due to be released early next week at which point we will be able to re-release the NNS Dapp. This will solve the problem @coteclaude is wondering about too.

There are a few learnings from this, one key one is that we need to be able to easily detect exactly which code version each of the NNS canisters is running. We can see the wasm hash, but its currently not very easy to tie that back to an exact commit.

1 Like

In our testing (myself included) we had all been unaware that we were testing against a version of the governance canister which was slightly ahead of what was live… so… everything worked fine in our tests haha!

2 Likes

This works! Thank you so much for your and team’s prompt resolution.

1 Like

Hi, Couple of minutes back I Clicked on “Spawn Neuron” and it is in processing for ever and after some time I realized that I lost my new ones. Now the button is grayed and could not be clickable. How I can recover my lost ones?

Now I can see My Spawned Neurons back. Please ignore my previous comment. Thank you.

Still not seeing the 1 ICP that I disbursed from a dissolved spawned neuron to a staked neuron last Monday. The spawned neuron disappeared as expected but the ICP never showed up in the target neuron. I manually refreshed the target neuron. I have been waiting thinking that the spawned neuron might reappear with the ICP. Anything else I can do?