Unable to login my Internet Identity Anchor to NNS dapps

Hi, I recently made an Internet Identity Anchor and when I try to enter my anchor number the NNS always ask me to verify through security key.

Last time I remember I was only given a seed phrase to recover and I never used any security keys.

Please help, guys…

Would be helpful to mention what kind of device you are trying to use, and if you have multiple devices used for login.
If it is a MacBook then try to restart as that helped with other people.


I used Xiaomi Redmi Note 10 with Android 11

I don’t use other device at all

I had this issue yesterday.

There is a simple fix: restart your computer (no joke).

If that does not work, please post here and please let us know.

If it does, definitely post here anyways!

1 Like

I’ve tried to reboot my phone many times but I stuck to this page again and again.

What should I do?

1 Like

Ok let me ping the relevant folks in team who may know more.

1 Like

Many thanks @diegop … Do you guys know anyone from DFINITY to contact about this particular matter?

1 Like

I pinged them, but can you please make a ticket here so so someone from Dfinity can help help your particular case: https://support.internetcomputer.org/hc/en-us/requests/new

You can link this forum thread and also mention me.

1 Like

Hi @z3z3 ! I’ve contributed a bit to Internet Identity, let me see how I can help. Can you clarify how you created your anchor?

I recently made an Internet Identity Anchor and when I try to enter my anchor number the NNS always ask me to verify through security key.

You say you created an anchor; how did you create it? Did you create it on the same device you’re trying to now authenticate with, i.e. the one you posted a screenshot of? Did you use biometrics or a FIDO device like a Yubikey?

Last time I remember I was only given a seed phrase to recover

Do you mean that you were asked to copy the seedphrase during the anchor creation? That seedphrase shouldn’t be used for day-to-day things like login to the NNS dapp.


Here’s the chronology:

I’ve only used 1 device (my Xiaomi Redmi Note 10) to sign up via NNS App installed on OS Android 11. It was Friday 4th February 2022.

After I got my Internet Identity anchor number, the seed phrase was only shown to me on my phone screen and I wrote them down on paper then clicked the copy button.

I remember that I only used my phone’s fingerprint sensor to authenticate. Once I managed to log in, I sent some ICP coins from my other wallet to my NNS wallet address then staked them for 1 year+.

Yesterday (6th February 2022) I tried to log in again using my phone (yes, the same phone) and I found out that the NNS App asked me for security keys via Bluetooth or USB connection.

That’s why I decided to start this new topic to get help from the forum.

Many thanks @diegop , I’ll try your suggestion. It really means a lot for me.

1 Like

Thanks a lot, this is really useful!

I’m going to assume you used the same browser on Feb 4th and Feb 6th. It looks like the Redmi Note 10 may have cleared its WebAuthn credentials store. This is basically a local database that contains the key for your Internet Identity login, and that database is unlocked when you use the fingerprint reader. This issue of the store getting wiped is known to happen on Safari, but I hadn’t heard of Android browsers doing this on their own (I’m assuming you didn’t clear your browser data manually).

If my assumption is correct then the problem should be fixed by re-adding the device. This is the process:

  • Login using your recovery phrase that you copied (using the “Lost access and want to recover?” button)
  • Re-enroll your device (click “Add new device” and follow the steps)

That should allow you to login via fingerprint again. If after that the issue surfaces again then we’ll need to look deeper and figure out why your browser keeps wiping its webauthn credentials store…


Today I tried one suggestion to recover by adding a new device (using the same Xiaomi Redmi 10 Phone and it’s fingerprint sensor)… and it magically worked :sweat_smile:!

I’m glad now that I can access again my NNS App wallet but I think it’s kind of a weird solution for me as Internet Identity user to use the same device and had to register it as a new device.

1 Like

Well I’m glad it worked! It’s really surprising that the webauthn credential store got wiped. Please let us know if this happens again!


Hello, I have a question about login to the NNS.

Since today I can no longer log into my NNS wallet (Internet Computer Content Validation Bootstrap) on a MacBook and my current Chrome browser.

I was supposed to use a USB stick for my security key, but in the past I didn’t need a USB stick for login.

Did I miss something there?

No, you did not miss anything. We have seen user reports on this. But fix is simple: can you please restart your MacBook? It should work then.

If it does or does not fix it, can you let this tread know please?

1 Like

huch, after a restart of my MacBook the login works as expected :sweat_smile:

Thank you for the hint.

1 Like

Glad to hear it worked!

Thank you very much @nmattia