Lost access to NNS dapp account

All

I hope you can help. I have been using my iphone 12 to access NNS dapp since I started staking from July 2021. This uses my face ID to get into my account after my Identity Anchor. Now it doesn’t ask for my face ID and say’ Do you want to sign in to “identity.ic0.app” using a security key’. I clearly don’t have a security key so I’m not sure what has happened here. My initial assumption was it could be due to a iphone update?

Secondly, I tried to click the Lost access and want to recover option - For this I used my seed phrase to try and recover but it keeps tekking me ‘Invalid Seed Phrase’. I’m 100% sure the seed phrase is correct as I had copied it down in several places.

What has happened here? It seems like my phone has been unlinked from my account maybe but then I don’t know why my seed phrase isn’t working…

1 Like

In your seed phrase did you also include the number in the beginning or just the words?

Also, try it from a few different browsers. For example if I’m logged into a different Google account in Chrome on my Mac, it won’t recognize it and treats it like a new device. Maybe you have some change similar to this?

Included the 24 words - not the number. Thanks

Did including the number solve it?

It’s showing the same error on both my chrome browser and my safari browser which are the two I used to use to log in, but thanks for the suggestion

1 Like

Both ways not working unfortunately (with or without the number)

And I assume you triple checked that the anchor number is correct. Do you have any other device connected to this II?

Yes I checked this. Unfortunately I only have it on my iphone connected to this and not any other device. In hindsight I would have connected another device but didn’t realise I’d run into such a problem having the seed phrase

Also make sure you’re not in incognito on any of your browsers.

I’m not, although apple did change their ios recently and wondering if this might have caused an issue

In iOS try to go to Settings → Safari → Prevent Cross-Site Tracking should be off. Not sure if this is the problem here, but that can sometimes cause problems when you’re trying to log into dapps using the II. If this doesn’t solve it, make sure to put it back.

Thanks just tried that and it didn’t work also

Is there anybody knowing you have your II on your phone ? And if it is the case : is anybody of them having access to your phone ?

Could you try using your seed phrase through your computer to reset devices and then add your iPhone back?

1 Like

Seems to come up with the exact same error - wonder if that is because it doesn’t recognise the device?

Even when you’re trying to use the seed phrase? Make sure you don’t have a space at the end or beginning of the seed phrase you copy paste.

1 Like

No one really knows I own ICP and my close family and friends don’t really know much about crypto so I doubt there is any problem there

Good. If you checked the typo multiple times, you can check the security settings of your browser.

On OS X and iOS, clearing Safari’s browser history leads to the user’s registered WebAuthn keys being deleted from the secure enclave, and authentication with these keys is no longer possible. Unless you saved your backup seed phrase, or have authorized another device, you may have lost access to your account permanently. Did you add any other authorized devices?

You may be using the wrong anchor id number. When Internet Identity generates a seed phrase, it usually prefixes it with the anchor, i.e. a seed phrase foo-bar-baz will be shown as 1251491-foo-bar-baz.

It is possible the recovery phrase was removed by mistake, or someone else got access to your account and removed it for you effectively locking you out. The recovery phrase is not immutable, it is just another mechanism that can be added or removed. We’re updating the docs to clarify this.

Are you sure that you’re using the correct recovery phrase and correct anchor id? It should begin with the anchor id. Did you try restoring your account with your recovery phrase using a new device?

The seed phrases consists of hyphen-separated english words (english: in the past we’ve had issues where browsers automatically translated the seed phrase). Can you confirm all the words are english?

3 Likes