Can not login to NNS anymore via Android 11 device. Internet Identity problem?

Hi

I am not able to login into the NNS anymore. I believe since the UX UI upgrade. My anchor got reset and I am not able to log into anymore.
It asks me to use a security key with my device, but I am not able to do that on my phone. I want to use the fingerprint reader but there is no option to use that. See attached pic.

I use Google Android Version 11 on a Google Pixel 2 phone.
Chrome Version 102.00.5005.125

This may seem an odd advice but have you tried restarting your phone? If you see that screen it means your browser thinks that it doesn’t have any relevant web authentication credential available internally, so it wants to look for such credentials on external devices. We’ve seen Android sometimes getting confused about its own credentials, although admittedly that seems to be happening on Samsung phones more often than on others. But in such a case, restarting the phone (or even just the web browser) usually resolves the issue.

This is completely unrelated to the NNS front-end dapp update, it is related to internet identity.

If restarting the phone doesn’t help: do you have any recovery mechanism associated with your identity anchor?

I have restarted the phone and browser. There is no change. Still same problem.
I have recovery mechanisms via desktop that work fine, but Id still like to use the NNS app on my phone.

Why is there a problem with the internet identity on my phone? My amateurish take would be that my phone is too old and internet identity is only optimized for new devices.

funny how no one cares. gives me confidence.

One common scenario that can potentially cause this is changing the authentication methods in your phone on the system level. Such as turning off FaceId/Fingerprint etc. I don’t know exactly what happens after re-enabling them. Normally re-enabling should give your phone access again.

I am wondering if there is a scenario in which the phone can lose access, for example completely resetting the fingerprints and registering new ones. Because in the end the access keys live inside the biometric sensor. I don’t know the exact behaviour of all types of biometric sensors on all types of phones.

Your anchor doesn’t necessarily “reset”. The devices used to authenticate yourself will remain intact within your Internet Identity, unless it is manually removed.

Did you by any chance format/reset your phone during that period? If so, that would be why this is happening. If not, very strange, but it’s not the end.

You can go to the Internet Identity login page → Lost Access? → proceed with the recovery of your II.

You’ll need your anchor and seed phrase.

I appreciate the replies. However I do not think the issue is on the endusers end. Hence why I am writing in this forum.

I havent changed anything on my phone for the past two years. No updates, no reset of the phone, no reset off the finger authentication. My phone settings are the same for the past two years. I also do not get any Android anymore.

I am not able to perform the lost access process on the ID login page. Same problem occurs as with login.
I am writing in this forum because I thought maybe one of you developer cracks can setup a enviroment with the old Android software and test, if the ID works on older devices or not. I would do it myself but I simply dont know how.

We know that the ID doesnt support any other browsers than Chrome, so my logical thinking tells me that maybe it also doesn’t support older Android/Chrome versions.

thank you!

hey Ray - if you can access the NNS from your desktop, you will be able to restore access from your phone.

do you have a recovery phrase or security key you’re using in the “lost access” page?

another option is to sign in to identity.ic0.app on your desktop and check if your phone is still listed as an authorized device. if it is, then something happened with your phone like you cleared your browser history and the key was lost. try clicking on “Add new device” and follow the prompts to add your phone again.

1 Like