Couldn't use android device as identity validator

I am trying to use android device for validation instead of usb key from my laptop browser. I couldn’t get authenticated. The system waits indefinitely.

My configuration:

  • Linux x86_64 (Manjaro - kde)
  • Browsers I tried with Brave,Vivaldi,Chromium and firefox
  • Bluetooth ON with phone disconnect bluetooth ON phone connected

I could logged within the phone. I also try to create a new anchor using phone as validator when I opened the qr it wait on page indefinitely.

Is someone use linux and android successfully ?


Hi @rbolog

So if I understand correctly, you are trying to login to your desktop browser using your phone as an authenticator (connected via bluetooth to your desktop machine)?

I just successfully authenticated on macOS (unfortunately I don’t have Linux available) using Chrome and my Android phone (via Bluetooth). Did you get the following notification from chrome and the corresponding push message?

Screenshot 2022-06-23 at 13.34.37

Could you maybe record a video / take some screenshots of the process? Currently, it is unclear to me, at which point the process fails.

1 Like


Thanks, I got a pop-up as you (step 2) but I never get the notification on my Phone. I tried with 2 devices. I also tried to add again the phone I did not get the notification.

This is a new situation. I had tested it when I created my identity several months ago. With the same hardware but different software versions

I have moved up one step. I get the notification on my phone. (I had blocked notifications for the browser :roll_eyes: :flushed:), but when I accept identification it doesn’t seem to go back to the sending browser.

Finally and after a lot of testing including another laptop under the same linux which works. I conclude that I have a hardware problem with my main machine.

So Linux && (Vivaldi || Brave) == Ok

Thanks for the advices!

1 Like