Why are NNS entry requirements so high?

So I’ve just loaded some ICP (and by some I mean a fraction of a token) and I tried to stake a neuron, and I was met with the lovely error message of min 1 ICP. Now currently I can’t afford a full token but I’d still like to be able to participate in governance. I’m no expert on consensus or governance algorithms, but there have been other chains (in specific Terra) that allow users to vote even with fractions of tokens, why isn’t this possible on the IC?

EDIT: I know what’s considered “high” is subjective, but in my opinion I believe that accessibility is a priority


Limit of 1 ICP? That doesn’t sound good. At the moment price of ICP is around 400$, which is already a high barrier to entry. Imagine the price shooting up even further (which is the hope). That would make the entry barrier even higher, and would be counterproductive for the platform governance as a whole, giving more power to the wealthy people who can afford purchasing whole ICP’s.

1 Like

Hi , I’m not a developer , I wanted to know if anyone knows how I can get the NNS application . I did generate the principal identifier and the private key on the terminal . After that I’m confused and I don’t know what to do . Any help to clarify is appreciated

not the right thread, mate. Might wanna start your own topic if you’re having trouble :slight_smile:

1 Like

I have a problem with NNS. I transferred ICP to my account on NNS. Transaction came there okay. After that I tried to stake my ICP. Staking process somehow did not go through (I did not get to choose the locking period). Now my account balance is almost zero and I see nothing on Neurons page. I checked the transactions from my account in explorer and there was this staking transaction but now I can’t see my ICP anywhere.

I submitted a ticket few hours ago and also, some guys on Reddit complained they had the same problem.

Don’t worry I staked 2.5 tokens and It then it disappears and you see nothing under the Neurons Tab. You look at you ICP balance and all your tokens are gone but they have been transfer to a wallet address (can only assume the staking address), but nothing appears under the Neurons Tab. No neuron ID, no lock up times… Nothing, just the ability to stake again.

Raised a support ticket… first response was to enter the developers forums, I cant post in LOL. Second response is a escalation to internal support. Not holding out much hope at the moment. Seem like i have really blown some cash.

oh dang. well at least theres a tx confirmation there, really hoping that this is just a frontend issue and not a problem with the NNS canisters…

Looks like this post got withdrawn, is there any way you could elaborate on the issue of this topic?

@Jello @Vee7Vee Staking problems within NNS app - #2 by kpeacock looks like the issue has been identified and a fix may be coming soon, its high priority.


Hello. i can’t DM you on this forum, i have same problem. How i can contact you?

Here is my experence: if you stake icp for Neuron, and set the stake time, you can see the staked icps in Neurons page.

and you click on your accout double, it will enter the all transactions’ details