Upgrading my first app deployed to IC- upgrade doesnt seem to be working

I have deployed the demo counter app to the IC …


… now after running …

dfx canister --network ic install --all --mode upgrade

… and receiving what seems like good logs and no errors (see below), when i refresh the above link the app is still not updating / showing the changes that i have made.

  1. is the above the correct command
  2. Is there anyway to see what’s deployed to the canister


Hmmmm…did you try deploy instead of install? What version of dfx?

Ok so …

dfx deploy --network ic

… worked fine and i noticed in the logs it seems to use upgrade for the canisters …

Upgrading code for canister slp_ui, with canister_id b4w7y-yyaaa-aaaah-qac4q-cai

… ill double check my service canister to see if it has lost the state.

My version is 0.7.0 .

So just to confirm …

dfx canister --network ic install --all --mode upgrade

… should work ?

That should work, but be sure to run dfx build to compile the code first.

Here are a couple good docs on the topic:

Working with Canisters

Info page for dfx canister

ok cool,

My locally dev process is working fine - just had this little issue with re deploying to the ic.

This looks to have fixed it, so thanks for all the feedback.