Thread 'main' panicked at 'Missing node signing public key', crypto/src/

I wanted to have a test instance of my dapp running on the main net with different canister ids to make sure the code works in production.

I have two copies using the same codebase with the only difference being the canister ids for the different canisters (asset / backend).

When I try running the original, everything is fine. But when I run the copy I recently started getting this error:

Jan 25 17:28:39.226 INFO Executing “/Users/andrewchepreghy/.cache/dfinity/versions/0.8.4/replica” “–replica-version” “0.8.0” “–config-file” “/Users/andrewchepreghy/Projects/Personal/Internet Computer/ICmoji Origins Test Instance/icmoji_battle/.dfx/state/replicated_state/ic.json5”, Application: starter
thread ‘main’ panicked at ‘Missing node signing public key’, crypto/src/

How do I start to debug something like this?

Have you tried removing the .dfx folder / deploying from a “new” project with a clean .dfx folder?

1 Like

Not yet. Would it mean that it regenerates the canister ids? Or the wallet address? How could I connect the project back to the existing canisters on the main net?

AFAIK the canister IDs are kept in “canister_ids.json”, although I haven’t tested removing the .dfx folder after pushing to production, so maybe do it first with the “debug” version :slight_smile:

Do you know what is stored in the .dfx folder? So when I delete it and rebuild, what is it that gets regenerated? I assume some private keys could be among them hence your suggestion to delete and rebuild.

Eventually this was the solution, thank you! Not sure what was messed up in that .dfx folder

Not sure what exactly causes this behavior, but I’ve had some weird errors in the past when moving the entire project folder, that would solve itself when moving just the code. So I assumed it has something to do with the .dfx folder, and moved on :slight_smile:

1 Like