Seed Round Access

@LefterisJP for just a little bit more security, you could use a virtual on-screen keyboard to input the password on that machine. That gets around any possible keylogger. It’s very impractical (understatement) for a virus to be taking screen video recording the whole time, unless someone was specifically after you :slight_smile: But keyloggers are much more common.
EDIT: actually nevermind, probably most keyloggers will catch input from a virtual keyboard just the same.

Appreciate your insight. This was the only method that worked for me. Virtual machines on Mac OS running latest Ubuntu. I imagine Windows users had to do the same.

1 Like

Or use an app like ReiKey to alert the user to keyboard logging.

Thanks for the clue! I looked through governance.proto as well as

I found reference to these two methods

pub fn get_neuron_info(&self, now_seconds: u64) -> NeuronInfo {
pub fn stake_e8s(&self) -> u64

We know that get_neuron_info method works, but stake_e8s does not appear to be exposed?

dfx canister --network= --no-wallet call $CANISTER stake_e8s "($NEURON_ID:nat64)" --output=raw

The Replica returned an error: code 3, message: "ICO302: Canister rrkah-fqaaa-aaaaa-aaaaq-cai has no update method 'stake_e8s'

dfx canister --network= --no-wallet call $CANISTER stake_e8s "($NEURON_ID:nat64)" --output=raw --query

The Replica returned an error: code 3, message: "ICO302: Canister rrkah-fqaaa-aaaaa-aaaaq-cai has no query method 'stake_e8s'

This is still fundamentally strange. How is a user supposed to verify what is staked in their neuron? And then of course, I couldn’t find anything about understanding what reward balances are or how much rewards can be spawned out of a neuron without touching the amount of stake locked behind the dissolve delay.

Thanks a lot.
I created a bootable USB stick with the latest Ubuntu with my air-gapped machine. Worked great.

1 Like

Aha so you just do it all in a live USB with latest ubuntu but from the airgapped machine. Yeah that would also work! Great :slight_smile:

1 Like

how long will the kyc take ? seems it’s already 48 hours, but when i try to send the coin, it still show
“Neuron 11XXXXX is not kyc verified”

Yes I’m still having the same issue, but I’m wondering if it’s maybe linked to the NNS upgrade? Any devs out there have an ETA for when the NNS upgrade will be completed?

hey guys~ waiting does work

1 Like

3 days after the KYC verified email.

1 Like

The same problem occurs on macos

1 Like

You mean the subaccount error? Check the updated docs, they fixed the command and it works now.

1 Like

I’m attempting to disperse my 0 dissolve delay neuron and getting the below error message, anyone know where I’ve gone wrong/what it means? Any help would be appreciated…

An error happened during communication with the replica: error sending request for url ( http2 error: protocol error: not a result of an error
error: The following required arguments were not provided:
< blob >

didc decode < blob > --defs < defs > --format < format > --types < types >

For more information try --help

any seed round investor get their coin?

Not having much success. I’m thinking I might just wait for the Ledger hardware wallet support if I can confirm that’s it’s going to be compatible and coming in the near future.

@ililic are you able to confirm whether the pending ledger hardware wallet support will also be compatible with seed round donor and early contributor 12 word mnemonics?

I believe so - Keysmith uses BIP39 wordlist which is compatible with Ledger wordlist and is a pretty robust industry standard at this point.

Ok great, thanks for the reply. I think I might just wait for hw support then and hope it works. I know it’s probably a “how long is a piece of string” question, but if you had to guesstimate, do you think ledger support will be released in a matter of weeks or months?

Hard to give an estimate because security reviews are dependent on external parties as well as approval processes by the hardware vendors themselves, but it is work that has been ongoing for some time and is a high priority for the team.


I am using an air gapped approach and all steps have worked for me so far.

However when I disburse a neuron, nothing actually seems to happen. I just get a successful Request ID: 0xac1a33350c69291cffc25ad92959b933a27fb40f4f3849f6ff1fe9e9b1268d19

When I later check on the neuron, it is still in state dissolved but no ICP have been disbursed.

  variant {
Ok = record {
  dissolve_delay_seconds = 0 : nat64;
  recent_ballots = vec {};
  created_timestamp_seconds = 1_621_187_677 : nat64;
  state = 3 : int32;
  retrieved_at_timestamp_seconds = 1_621_247_750 : nat64;
  voting_power = 2_085_953_945_951 : nat64;
  age_seconds = 48_257_688 : nat64;

I have tried disbursing 4 times over the span of a few days. Is there any way I can use the REQUEST_ID to find out what is failing? It does not seem to be KYC since I received an email saying I was verified on the 12th May.


Shouldn’t age be reset to 0 when state = 3 (dissolved)?

1 Like