Seed Round Access

4 years ago (Feb 2017) I participated in the seed round.

I had 12 words to access my ICP. I haven’t seen any further details or instructions about how us early participants will be able to access our ICP on Genesis.

Please share.

Thank you.

8 Likes

Same.

Further details would be appreciated. I am keen to contribute towards network governance from day 0 but have not received any information regarding token retrieval. Please can someone from the Dfinity Foundation provide further instruction ASAP?

3 Likes

I would also appreciate an answer to the same question!

2 Likes

I also participated in the Seed fundraise in Feb 2017.

Where can we find instructions to access our ICP tokens? Looking forward to participate in governance and using the network.

1 Like

We are in the same boat, brothers.

2 Likes

Documentation released yesterday indicated seed allocations will be locked pending KYC. But with launch days away, and no information about KYC process, will seed participants even be able to access their ICP upon launch?

2 Likes

Is there something specific that mentions seed allocations or are you talking about the NNS documentation that states “When new neurons are created at Genesis, they have GenesisKYC=false. This restricts what actions they can perform. Specifically, they cannot spawn new neurons, and once their dissolve delays are zero, they cannot be disbursed and their balances unlocked to new accounts"?

Dfinity Foundation, can we please have some information regarding the KYC process for seed round participants?

3 Likes

Come on Dfinity, you had almost 4.5 years to ask seed investors to do KYC. Are you really going to launch first and only then start asking them for information and start providing documentation for those who financed and enabled you in the first place? Seems quite dishonest actually.

2 Likes

I was told more info would be made available tomorrow for the seed rounders. Not great if they allowed all other groups to KYC pre-launch, but then spring this on us post-launch. If this was going to be required, it could have been sorted a long time ago.

I’m still not sure how seed rounders would go through KYC.

All we have is 12 words.

I’m not particularly interested in sharing my 12 words over the internet to CoinList to gain access to my ICP.

I’m not sure how they intend to make this work.

I was hoping there would be hardware wallet support as I’m really not keen on entering my seed anywhere online, or handing it over to any trusted third party. But from the NNS documentation it seems that all neuron balances will be locked pending KYC approval.

1 Like

Info was just released at dfinity dot org slash seed

2 Likes

when i install keysmith i get this “install: keysmith exists but is not a directory” and when i try to run keysmith i get “-bash: keysmith: command not found”

anyone can help me with what’s up?

i’m using mac osx with intel chip

1 Like

getting “EOF while parsing a value at line 2 column 0” when trying to ping or create the message.json file (ubuntu 20.04).

Btw. can you create a discord server with a proper support channel? This is ridiculous ffs

1 Like

Is it possible for the team to create an interface so that users without a technical profile can claim the seed tokens without problems, please? I don’t like to play commandos when money is involved.

(And for those of us who are not Linux and Mac users). Thanks.

5 Likes

Hi! I follow the steps for claim seed participans, but in the KYC proccess I have an error, when I try to submit my info and documments appears an error “Invalid Principal ID”, I try a lot of format, with passport, National ID card, Driver liscense, all, but always the same error…

is it happening to you?

Thanks!

1 Like

Yup there’s going to be a lot of seed people that are unable to access until a better interface is out.

1 Like

the EOF error is resolved by using
echo {} > dfx.json instead of echo > dfx.json

the not a directory is resolved by this

Separate the two sudo instructions across two lines. They pasted that in and it lose the line break.

(thanks alex sillytuna)

so you would need to run

sudo install -d /usr/local/bin
sudo install keysmith /usr/local/bin

https://dfinity.org/seed has been updated with the correct steps!

1 Like

The KYC page seems to be struggling, any likely resolution. It throws tons of 400 and 502 errors on the websocket polling. I can’t seem to get it to register the face photo at all, and at times when trying to access the page it throws a 502 error. The first time I visited it early this morning, I did get the photo uploads to work but when I submitted it had a database error saying the user id was missing, even though I filled the form completely (looked like a different field from principle id).

1 Like

I’m also having the “Invalid Principal ID” issue and I can’t finish the KYC. What are we supposed to write in this field? I tried ID card, passport no., driving license … nothing worked

1 Like