Piped - Youtube FrontEnd on the IC - Replica Error on Mobile

I have been using Piped, a YouTube frontend on the IC. Link to app:

This morning, I attempted to access it via my mobile phone and received the following error:
“Replica Error (3): “IC0301: Canister y3f56-pyaaa-aaaad-qaxoq-cai not found””

I used two different browsers on my phone with the same error. Yet when I access this app on a computer, it works as normal.

Anyone have an idea on what the possible issue could be? Sorry if this is in the wrong section

Interesting observation: Not only can I not access it on mobile, but If I use the private browser feature of all the common browsers on a computer, it provides the same replica error…

Very strange… Any ideas?

I suspect that the front end assets for the version that is working for you are cached in your browser, which would explain why it doesn’t work when using a different device or private window.

Issue is, I use this app on my mobile and computer regularly. As of today it stopped working on my mobile, on all the browsers I have. Previously all my mobile’s browsers worked, and I have not cleared any caches. Could it be possible that the canister ran out of cycles?

Maybe. I’m not familiar enough with canisters that have run out of cycles to know what they look like.

The non-raw URL shows a bit more info: https://y3f56-pyaaa-aaaad-qaxoq-cai.ic0.app/

Interesting find, I assume the canister creator hasn’t made any changes. I can still use the app on my computer, which makes the idea that it ran out of cycles slim, hard to say

Failed to fetch response: Error: Call failed:
Canister: y3f56-pyaaa-aaaad-qaxoq-cai
Method: http_request (query)
“Status”: “rejected”
“Code”: “DestinationInvalid”
“Message”: “IC0301: Canister y3f56-pyaaa-aaaad-qaxoq-cai not found”

If there’s a separate assets canister then perhaps only that is down.

Or everything happens in the browser and calls to YouTube still work.

I haven’t used the app so don’t know if that’s what it does.

Tried sending cycles to that canister, ended up getting refunded… So might be a different issue

Seems it is indeed cached in my browser… Canister doesnt seem up anymore, bummer