NNS Down, and Internet Identity Down - No VPN, No Browser Works

Today I could not reach the NNS, or Internet Identity websites using both Safari and Chrome on my Mac. I also tested Firefox and Brave, none works.

I used two domains:
https://identity.ic0.app → which usually works fine
https://nns.ic0.app → which usually works fine

and the new .internetcomputer.org:


I’ve attached screenshots for your team to troubleshoot.

Please fix this, I realize it is a weekend, but I hope you have someone who can take a look or it can be fixed tomorrow.


P.S. Some screenshots from Safari and Chrome attached.

Everything is working fine for me.

Edit: On a mac using Safari.

Everything is working fine over here aswell.

You can try these 2 things

  1. Check that your time is correctly updated.

  2. Delete temporary files from the website.

Recharge and you will see that it works correctly. :slightly_smiling_face:

1 Like

Agree with asumption of @FranHefner. From your screenshots, it seems that the local time on your device it too far away in the future or in the past with the IC. Usually this issue can be solved by synchronizing the local time.


Thanks @FranHefner and @peterparker indeed that was the issue, the clock was not using the automatic beacon from Apple, but just the Mac’s internal clock.

Everything works fine.

But this is intriguing, why is this enforced by the IC?

Every other website, including banking sites worked flawlessly, and so did the InternetComputer.org site, it was just these two critical websites that did not work, and probably DAPPs did not work, I just did not test yet.

Thanks for your help!

According documentation the ingress_expiry is a mechanism meant to prevent “replay attacks”.