Issue accessing nns wallet

Whenever attempting to access the nns wallet, after clicking the log in button, it redirects to the internet identity authorization page where it then displays this:

attempted solutions include: 1.) tried logging in using and and it gives the same issue. 2.) tried using different browser. 3.) tried using different device. 4.) clearing browser history. Every other ic app logs in fine. It’s just the nns wallet that gives this issue

1 Like

Perhaps you are closing the nns page, after opening the identity page.

Hi @Jesse

This screen is shown, if Internet Identity detects that it was not opened by another tab (or if that information is unavailable).

Could you maybe record a quick video of the whole authentication process that brings you into that state? That would be very helpful.
I tried reproducing, but was not able to do so…

I resolved the issue. The problem was that there was no default browser set. So each time the device performed the redirect, it was opening an entirely new window as opposed to just opening a new tab. To resolve the issue, a default browser had to be selected… more specifically, the browser that is used to access the nns wallet has to be set as the default browser that’s used for any redirects from the nns wallet


@kpeacock is it something that can be prevented in agent-js? not sure can detect this but thought about pinging you just in case.

Sometimes you just have to logout and login again.
I hope it works

I started noticing this happening a lot this week myself too - Firefox stopped working entirely for me out of the blue this week. There’s no current agent-js configuration I can think of that would fix this, to my knowledge.

Chrome works though, even when it’s not my default browser (Android)

1 Like