Identity Connections Issues

After creating my NNS account yesterday, I chose my phone as my device for the passkey. It worked on the initial login. I proceeded to move my ICP from wallet into my NNS account for staking.

However, while exploring the site as a first-time user, my session abruptly “timed out” and closed. Ever since, I have not been able to log back into my account where I now have all of my ICPs.

When I try to connect, my phone is initiated but it doesn’t connect. After some wait, it would say “Device couldn’t connect” (screenshot attached). I have only my identity ID, no pass phrase, so unable to reset.

I created another passkey just to test whether the issue is permanent and whether it would resolve the issue, but to no avail.

I need help badly if anyone can guide or assist with a solution or workaround for my issue, please. I have attached the error messages.

Thanks in advance.

FYI - I am using a Samsung Android device

You need to log in to your account using the same browser that you created your NNS account.

I don’t understand exactly what you mean by “I chose my phone as my device for the passkey.” But here are three things that may help:

  1. In my experience, Samsung’s implementation of web authentication is a bit buggy and unreliable. Restarting the device may help, at least it often helps in my case. (This is a general issue with Samsung devices, it’s not specific to II. I don’t know why they are not fixing it.)
  2. If the passkey is on the phone, have you tried logging in to from your phone?
  3. This doesn’t help right now, but it’s always a good idea to set up a recovery device (or recovery phrase).