Error: Certificate verification failed

Hello everyone,

Before 5 days I was able to upgrade and reinstall my canisters on Internet Computer network. Today I tried to deploy the canisters or reinstall them and I get this error:

Error: Certificate verification failed.

How I could fix that?

I am using Macbook Air 2020 M1.

Thank you !

Hi @ThanasisNta, could you provide some more information? This is quite little info to entirely diagnose the problem.

This error message means that the received response could not be validated as being an authentic and authorised IC response. To figure out where the problem lies, could you please tell me:

  • Version of the program (like dfx) or library (like agent-rs) used.
  • When did it work the last time and on which version was that?
  • Exact command you used.
  • If there is more output than just the error, I’d love to see a bit more.

For some reason today the same commands work without throwing me an error. I cannot understand which was the problem since I did not change the code or and I did not execute more commands than those below:

DFX version: 0.9.3

  1. The first command was: dfx canister --network ic --wallet <wallet> install <canister> --mode reinstall and the first time I got an 503 error. I tried this command again and I got Error: Certificate verification failed.
  2. The second was: dfx deploy --network ic --wallet <wallet> and I got directly Error: Certificate verification failed.

After that both commands were throwing this error Error: Certificate verification failed.

Magically today those commands work again without throwing an error!

Weird. 503 usually means that a boundary node has an issue, and in my experience usually doesn’t last more than a minute or so. But I don’t know why the certificate would not properly be served… I’ll ask around if anyone’s got an idea.

Is your canister on the subnet mpubz by any chance? There was an incident on there yesterday.