Sorry, there was an error loading the details of the canister. Please try again later

All my linked canisters here

show this message

also calling authorize for my cycles wallet returns () with no error
but isn’t authorizing my web browser principal
I’m a controller of the cycles wallet and adding and removing controllers of the cycles wallet works

First time I’m hearing of such issues. Would you mind running dfx wallet --network ic upgrade and try again? Also, what exactly is the flow you go through when you try to authorize your browser?

This will only work if your NNS dapp principal is a controller of these canisters, too. Any chance you removed that principal from the list of controllers?

1 Like

after wallet upgrade
“Upgraded the wallet wasm module.”

now visiting cycles wallet canister URL
“Body does not pass verification”

canisters in after adding as controller
works :slight_smile: Thank you;
was just looking for an easy way to check and add cycles as a custodian;
think it would be nice to have both permission levels work
so the add and remove controller functionality disabled as custodian

is there anything else to try to get the cycle wallets web page working again?

Wow, that really shouldn’t happen. What version of dfx is that? I just tried with 0.12.0 (run dfx upgrade if you want to switch to that) and all worked without any problems.

Can’t still waiting on solution to this

If you put "dfx": "0.11.2" into your dfx.json for a project, any dfx calls within that project will use the version you pin it to. Anything outside of the project will use the main version you installed

Thanks again for all your help :grinning:
Will try that tomorrow morning :sleeping:

added “dfx”: “0.10.1” to config
dfx upgrade
dfx wallet --network ic upgrade
moved out of project scope after seeing warning about using “0.10.1”
dfx wallet --network ic upgrade
Upgraded the wallet wasm module.
“Body does not pass verification” now gone :slight_smile:
but now it’s just a white page
and in the console lots of this
“Failed to load resource: the server responded with a status of 500 ()”

That sounds like a boundary node/subnet issue. I’d give it a few hours and try again. If the issue persists, I guess we’ll have to dig more. I’m really sorry for all these problems.

Would you be willing to share your wallet’s ID so I can take a look myself? DM is of course fine, too, if you don’t want to make it entirely public.

Thank you :slight_smile:
will check back tomorrow

Oh, if you use the non-raw URL then it works:

Side note: If you have any financial/important data you manage on a site/canister, you should always use the non-raw URL. Otherwise you may receive forged data if you run into a malicious node.

1 Like

Thanks again, very important to know :grinning:

What do I set DFX_WARNING to?
“To disable this warning, set the DFX_WARNING=-version_check environment variable”

Probably just export DFX_WARNING=-version_check

1 Like

Thank you :slight_smile:
assumed I could just set it like I did with
but I’m guessing that was just locally scoped

If you do DFX_WARNING=-version_check dfx identity get-principal then the flag is only set for this one command. If you export it, it will live for the whole session in this shell (unless you unset it later, of course)

1 Like