526 Error when deploying on Windows (using WSL)


Today on a call with a Unity Developer, was trying to help him push an asset to a canister and it only broke on the “dfx deploy --network staging” moment.

It went on and on for a long time (>2 minutes) and then printed the error:

The replica returned an HTTP Error: Http Error: status 526 , content type “”, content:

What we did to rule things out was:

  • We created one from scratch, and surprisingly it succeeded. But if we repeat the (deploy) command, it will return the same error.
  • If we do canister install mode=reinstall it also gives the same error
  • If we do it on local deploy, it works fine.
  • In my computer the exact same code is deploying just fine (I use a MacOS).
  • Doing a simple ping works fine, so am assuming no DNS network problems.

The Unity Dev has a principal that is controller of the canister, so no “permissions” problem. Also no default identity, wallet has cycles, etc.

Because 526 error is “Invalid SSL certificate” we double checked if OpenSSL library was installed and is latest version (v3). I am now suspicious that something is breaking on the “opening a connection” to the canister for batch processing, but have no idea how to prove, further debug this.

Can someone from the DFX team help us out?


1 Like

This is very weird… I’ll ask the team if anyone has a clue.

Would you be willing to share the repo for reproduction?

Our first suspicion is that something with the definition of the network staging may be off. Would you mind sharing how you define that network and which version of dfx you’re using? (In the latest release dfx changed how it assesses some parts of network settings)

Hi Severin, thanks a lot for looking into this.

The version is the latest (0.13.1) and the staging definition is the one in documentation, see below:
Screenshot 2023-03-13 at 10.53.59

We have now tried with 0.12.1 and unfortunately gives the same error.

We are now suspicious that it is related with WSL directly and an issue we are having with Path not loading well (we are accessing dfx exec directly, and not the usual way (through path)). We will attempt to fix that first.

Meanwhile, we found a way to mitigate this (I upload the builds). So feel free to keep this on the back burner and only go deeper into it if more people come across this issue :+1:

Thanks for your help and have a great week!


1 Like