Bootstrap.js missing [solved]


Wanted to see the magic app with the domain and my code but I am missing something. So I followed the steps in the e-mail newsletter today but I faced this error when accessing the url.

Then I spammed the IC with the latest compiled bootstrap.js. However, the error persists. I also tried to change the entrypoint and included originally the assets folder.

Any other ideas?


When you created/deployed the canisters, dfx would have shown you two canister ids, just double check you’re using the canister id for the “hello_assets” canister, not the “hello” canister.

1 Like

Hi Ori,

Thanks for the reply and the tip. However, I tried both canister ids:

  "hello": {
    "ic": "lkgxr-pmfaa-aaaaa-aaaaa-aaaaa-aaaaa-aaaaa-q"
  "hello_assets": {
    "ic": "jvgaw-3umaa-aaaaa-aaaaa-caaaa-aaaaa-aaaaa-q"

Are you on the latest version? Run dfx --version and check you’re running 0.6.12. Also try force refreshing the browser window between attempts (Ctrl F5 or similar), that could help.

hi Ori,

Yes, I tried that and also went to the https url in icognito mode :sunglasses::nerd_face:. I am running 0.6.12 on a Amazon Ubuntu 18.04 instance. The errors seems to stick from worker.js but this makes no sense to me. I even kept the dfx network running in the background. I also tried the phonebook app from the tutorial and got the same error. On linkedup it did not find my OS it seems.

Is there any other motoko library with a frontend that I can try out?

Thanks for walking me through!

No problem. Hmm. You’re deploying this on the Sodium network without errors, with the --network ic flag? (You also shouldn’t need to run any network node on your instance for this).

Perhaps @stanley.jones or @hansl may have some thoughts on this too, if they have time today.

Yes. I also would like to write a blog post on about deploying my first app. It is just hard to write if I can’t get it to work :blush:.

Hi @factorlive,

Seems like there’s something wrong with your asset configuration. In your dfx.json I see you specified source: [ "src/hello_assets" ] which made dfx upload all the files in that folder as is. The source array specifies a list of files and folders to upload to the asset canister.

What you want instead is uploading the output of your build step (the webpack.config.js).

When accessing your frontend canister you basically try to download a index.js file at the root. If that file isn’t uploaded in the asset canister it will show not found as the error.

You can check which files are in your asset canister using list:

Hope this helps!


This is my key take away! Thanks and this helped a lot. The problem was that I had node not installed on my tiny Amazon instance :open_mouth:. So the dfx deploy command did not trigger the build process.