Backend Canister Build not working but doesn't throw error either. it just pauses

I’m trying to deploy my backend canister locally and when I type the dfx deploy command, the terminal just pauses at the following process in the build
dfx deploy dtc Creating a wallet canister on the local network. The wallet canister on the "local" network for user "default" is "sbzkb-zqaaa-aaaaa-aaaiq-cai" Deploying: dtc Creating canisters... Creating canister dtc... dtc canister created with canister id: si2b5-pyaaa-aaaaa-aaaja-cai Building canisters...

it doesn’t throw any error messages, it just shows that forever. I’ve tried restarting my laptop and doing dfx start --clean. no luck.

edit: I’ve upgraded the dfx SDK to the latest version, and have updated my mac M1 to Monterrey 12.4
still no luck.

update #1: the terminal finally threw an error. I’m getting this error message

rosetta error: unexpectedly need to EmulateForward on a synchronous exception x86_rip=0x140703523390965 arm_pc=0x140705948251264 num_insts=6 inst_index=3 x86 instruction bytes: 0x6215344901283465301 0x17042544937633142081
zsh: trace trap  dfx deploy dtc

update #2: I’ve tried uninstalling and reinstalling the dfx sdk. no luck with this either.

I found the issue. I had mistakenly imported a file from within that same file. I had a file importing itself and it was causing this response from the SDK. @diegop could you report this to the DFX team? the SDK should have an error handling message for when this sort of thing happens.

1 Like

Thanks! Reported and tracked