A beginner Question

Hi, everyone!
I am a beginner in development.
I have a question when I follow this instruction:


The Internet Computer | Documentation

Documentation for the internet computer.

In the step of “dfx start”, I waited for a long time.
But my terminal kept running and did not stop.

The information in the terminal as followed:
Jan 08 13:33:02.278 WARN s:fscpm-uiaaa-aaaaa-aaaap-yai/n:fkhwj-zhf3z-dbxze-csngl-coo6f-s7fyy-nsaqd-l47cr-6jwwm-seebb-nae/ic_consensus/block_maker Cannot propose block as the locally available validation context is smaller than the parent validation context (locally available=ValidationContext { registry_version: 1, certified_height: 2500, time: Time(1610112782277587000) }, parent context=ValidationContext { registry_version: 1, certified_height: 2562, time: Time(1610112778366285000) })"


I work on iMac Pro, macOS Big Sur version 11.0.1

Hi Adam

You’ll want to have two terminal shells open in your project directory, one is left running dfx start while the other is used to run other dfx commands, eg installing and calling canisters.

So try opening another terminal in the same project directory and continuing with the steps under “Register, build, and deploy the application“ on that page.

Another option would be to run dfx start --background.

dfx start runs a local internet computer. You’ll want to have this running along side your development flow. Simply open a new tab in your terminal or use the --background.

@enzo @Ori @cryptoschindler
Thanks to all of you!

After reading all of your responses,I do not know if I get the point. I understand this problem in this way,

It is right that the terminal which runs the command “dfx start” keeps running and never stop. Because it needs to keep running to keep the local development envrionment running, otherwise I can not develop.

Then the only problem is that I can not use the terminal which runs “dfx start”. So there are two solutions:
1.open a new terminal in the same directory and finish the following commands in this command.
2.use “dfx start --background” to make the terminal hide the running progress of “dfx start”,but “dfx start” still keeps running.

Am I correct? Thank you!


Yes that’s correct, great :slight_smile: