Unable to use pre-existing hardware wallet on new computer

Hello @ielashi, @peterparker ,

Linking you both in this forum as you both have offered support on hardware wallets in past forums/user walkthrough videos.

I’ve attached my hardware wallet to my NNS login some time ago. The Wallet shows on my token page on the NNS UX and has historically performed as appropriate. I’ve also added a hotkey for frontend visibility for staked neurons.

I recently built a new computer and linked my identity account. Everything performing as expected. However, when attempting to merge maturity on my HW neuron, the HW wallet doesn’t populate with the prompt to approve the request. The IC app is open as needed on the Ledger device. Not sure what steps I can take to rectify - anything you can do to assist would be greatly appreciated.

Some applicable notes that may be of use:

  • Ledger Nano X firmware is up to date, 2.0.2
  • I’ve successfully merged maturity on my HW wallet using my old computer. (Just tried with success - everything operating as normal on old computer)

Thank you both in advance!

Hi @ImagineChadParadigm

I’m a team member of @peterparker

Can you give me more details to try to replicate the issue:

  • Operating System of your old and new computer.
  • Which browser and version did you use in the old computer and worked?
  • Which browser and version is not working in the new computer? I think that for now only Chrome supports HW.
  • The button to Merge Maturity is enabled, and it opens the modal, right? The problem comes when you confirm, and you don’t see it in the screen of the device, is that accurate?

Thanks and sorry for the inconvenience!

Hello @lmuntaner ,

Thanks for the quick follow up! Answers to your questions below:

  1. [Old] Windows 10 Home Version 22H2 / [New] Windows 10 Home Version 22H1

  2. Google Chrome Version 107.0.5304.107 (Official Build) (64-bit)

  3. Google Chrome Version 107.0.5304.107 (Official Build) (64-bit)

  4. [Old] The button to merge maturity is enabled, and it opens the little prompt window underneath the “View Site information” lock when I approve the merge prompt. It immediately recognizes my HW device, and I can approve the merge on the wallet.

[New] The button to merge maturity is enabled, and it opens the little prompt window underneath the “View Site information” lock. However, this time it simply does not recognize my device. The IC app is opened on my hardware wallet, but nothing prompts me to approve the request. The front end itself appears to not detect that a HW wallet is connected.

Looks like I can upgrade my OS to Windows 11 version 22H2 (Thinking this may be the problem?)

Ok, both OS and browser are (almost) the same version with different behavior.

Did you try other actions with the hardware wallet? Do they all fail to recognize the device in the new computer?

Is the new computer using an older version of the OS? 22H1 vs 22h2? It makes sense to bring them to the same version at least and try again.

We haven’t seen this issue, but I will ask in the team whether someone has a Windows device to try this out and see whether we can replicate it.

Keep me posted, thanks!

1 Like

Hello @lmuntaner ,

Made a silly mistake that I am almost afraid to say publicly lol!

Long story short - I upgraded the OS, plugged in my HW wallet, and thought I was running into the same issues.

The prompt window asking you to verify that the HW wallet is connected to the IC is automatically detected on my old computer. However, on the new computer, I needed to physically click the device to approve the prompt window on the NNS. (Which means the frontend likely saw it on the old OS iteration and I was too clueless to realize) Literally that was the issue. Sheesh lol

Thank you sincerely for your assistance. I’m glad it was just user error!

1 Like

Hey, sorry, I see the message just now. Weird, I would have expected an email from the forum…

Happy to hear that everything is working!

We all do silly mistakes always and there is no stupid question. So, no worries!

Have a good week!

1 Like