Disbursing New Neuron Error. Hardware wallet Nano S


I am unable to disburse new neuron. I am getting this error when I approve the transaction with my hardware wallet. I have done this before and I have never encountered this issue. I set up a new antivirus and wonder if that might be causing the trouble. Please help! Btw, I disabled the antivirus, but it is still not working. :slight_smile: One update, I bought 1 ICP, and tried to increase neuron stake. I got the same error. The hardware wallet lets me approve it but then I get that error. Please Help


I have had the same style of error as well, also using a ledger nano s, I tried to approve the spawning of a new neuron via the ledger which was when I received the error.

It says at the very end of the error message "invalid length: Expected ECDSA-SECP256k1 signature with 64 bytes but got 234 bytes’

For what it is worth, my ledger is fully up to date. I tried rebooting my PC and disconnecting and reconnecting the ledger but it hasn’t made a difference.

1 Like

Yes, I am getting that very same error man. Hopefully, someone will be able to help us.

1 Like

I created a ticket. They came back to me. They wrote the following: “This would be what to expect from the expired certificate from this morning but it should be resolved now.”

It is still not working on my end. Let me know if it works now on your end.

1 Like

Here is what you will want to do.

First go to https://identity.ic0.app/ and authenticate take note of your internet identity/anchor number that you authenticate with and write it down, then confirm you have a recovery phrase showing. If you do, but don’t know what it is, delete it and recreate it and write it down somewhere safe (do not store online obviously) if you already have the recovery phrase showing on that page and know what it is grab it, you will need it. (Might also want to set up additional devices if you only have one but not necessary for what we’re doing here.)

Clear the cache and cookies/browser history of the affected browser (DO NOT do this without having your recovery phrase and anchor identity recorded and available to you or you’ll have no way of reconnecting to it and you will lose everything as far as I’m aware) then just recover your identity by inputting the anchor/identity number followed by seedphrase.

Remember you only get one shot at this so please do not clear the browser until you are certain all is well. Id go so far as to download a new browser and recover on that first before clearing cache and cookies, just to be safe.

But yeah, just clear the cache and it will work but be mindful of the risks in clearing it.

Good luck :slight_smile:

1 Like

Thank you, I will try that. I appreciate your help. :slight_smile: Cheers man.

1 Like

I opened up the app in a new browser, and it worked. I did that before but did not work, but the second time did work. cheers.

1 Like

Awesome, glad we’re both good now!

1 Like