Trouble setting up Quill

Hi all - beginner coder and ICP enthusiast here just trying to learn how to code with dfx and manage a neuron via the command line. I’m trying to get my laptop set up with Quill but running into an issue after following the build instructions on the Github page. I’m using a Macbook M1 processor and have Rust, Homebrew, DFX, and other software already installed on the computer. However, when I try to open Quill in Terminal I get the following error:

Library not loaded: /usr/local/opt/[email protected]/lib/libssl.1.1.dylib
Referenced from: /usr/local/bin/quill
Reason: tried: ‘/usr/local/opt/[email protected]/lib/libssl.1.1.dylib’ (no such file), ‘/usr/local/lib/libssl.1.1.dylib’ (no such file), ‘/usr/lib/libssl.1.1.dylib’ (no such file)

I also tried following the instructions on this page to no avail.

I realize this may be a novice mistake, but can anyone help point me in the right direction? Appreciate anybody that can chime in !!

1 Like

hey, i recently ran into the same error but with a different library. this should help:

2 Likes

Thanks for the quick response here @cryptoschindler ! I will give this a shot.

1 Like