Getting Started - First curl command gives me cert expired error

Hi all, I am trying to get started with IC and trying to install DFX. But when I execute the following command,

sh -ci "$(curl -fsSL"

I am getting the below error

Can someone help me with that please?

That’s probably the same error as following: Failed to install SDK. What's the reason? Please help me! - #2 by peterparker

Documentation and script have been moved to a new domain,, but the docs itself has not been updated with the new link / domain.

1 Like

Thank you @peterparker . But i am getting the same error. Seems earlier the issue (issue in the thread you pointed) was HTTP 404. but now it is a certificate expiration issue. I am not sure if this is an issue in curl or from the website.

Damned, I was hoping it was the same issue. It seems the certificate is not valid anymore :disappointed:

1 Like

i had the same issue, the cert expired on my macbook with macos mojave, replacing the cert with a new version did not fix it, but after updating my operating system to a more recent macos it solved the problem

1 Like

I thought this was more of a server side issue. Is it not?

if i am not wrong, its has to do with the certificate associated with your curl command which is local to the machine you are running it from

1 Like

Let me try. Right now my openSSL is something called LibreSSL. I will remove that and re-install. Thank you for the tip!

1 Like

I installed a new version of curl which comes with openssl 1.1.1. Still the issue is there.

Hi @FDX, did you solve the cert issue?

If not, could you provide more details about your OS and ssl setup? Then we may be able to reproduce the issue and try to solve it.

Hey @lwshang I was not able to resolve the issue. I simply gave up. My OS is MacOS Mojave. I havent done anything specifically for SSL. Thank you for your help. Should I do something about SSL?

It’s likely that the SSL certificate bundled with Mojave is a bit old. From the macOS version history, Mojave is currently the fourth latest major version.
We are using Github Workflow for CI which can cover macOS Catalina and later. It is a challenge for us to guarantee it all works on previous versions OS.
We will investigate the option to also release the binaries through Github releases assets. While for now, the most straight forward solution is upgrading the macOS which did work for “protein” as said in his/her reply.


Thank you. Let me give it a try.