Dfx 0.14.1 is promoted!

This version is addressing issues experienced in the 0.14.0 release; we strongly recommend all users, especially those affected, to upgrade. We’ve withdrawn the release binary files for 0.14.0, making it non-installable.

Please see:


  • fixes issue which renders any SPA app unusable (/index.html fallback stopped working due to a recent v2 certification feature update)
  • dfx can gzip wasm module as the final step in building canisters
  • dfx deps subcommand
  • fixes and updates to asset canister synchronization process

All versions after 0.13.1 result in this error.
(Using Mac, OsX, Intel) I am most probably getting it because I was trying to install another clang/llvm on my Mac in order to get a Rust library to compile. Unless every Mac dev gets the same.

dyld: Symbol not found: __ZTTNSt3__114basic_ifstreamIcNS_11char_traitsIcEEEE
  Referenced from: /usr/local/bin/dfx (which was built for Mac OS X 12.0)
  Expected in: /usr/lib/libc++.1.dylib
 in /usr/local/bin/dfx

Are there any examples of how to use it?

I believe you’d need to update your MacOS. Which version are you currently on?

Hi ZenVoich.

I’m excited that you are interested in the upcoming dfx deps functionality.

This page introduces the relevant workflow.

So far no mainnet canister is “pullable” yet. I’m working on prepare some service canisters to be “pullable”.

dfx deps will be promoted to our community once we have “pullable” canisters on the mainnet.


Correct. Thanks. My Mac upgrades were struck and I had to reset Mac’s NVRAM. After upgrading dfx worked.

1 Like

After installing dfx 0.14.1 with the command listed here, the correct version isn’t showing up in my /Users/<username>/.cache/dfinity/versions directory (I see 0.14.0).

Also, when I try to install 0.14.0 using that command, I get a 404 error.

curl: (22) The requested URL returned error: 404 Not Found
dfinity-sdk: command failed: downloader https://github.com/dfinity/sdk/releases/download/0.14.0/dfx-0.14.0-x86_64-darwin.tar.gz /var/folders/lc/ptw97m4j7zg_snmcgx_pj1_40000gn/T/tmp.JpB8lIQ7/dfx-0.14.0-x86_64-darwin.tar.gz

What’s the best way to install/change between different versions of dfx since 0.14.x?

Have you tried running a command? It should then automatically install the cache. Otherwise you can do dfx cache install to populate that folder

Just forget that 0.14.0 ever existed and you should be good to go. The installation behaviour has not changed

Works, thanks! 20 characters

1 Like