Sender not authorized to use method

when dfx deploy canister into gw.dfinity.network error show follows:
The Replica returned an error: code 3, message: “Sender not authorized to use method.”
Wallet canisters on tungsten may only be created by an administrator.

Which version of dfx are you using?

dfx --version

Can you share the canister code or dfx.json that you’re trying to deploy?

0.6.26 if set --network ic show errors:
The Replica returned an error: code 1, message: “Canister 5demk-laaaa-aaaab-abbna-cai with memory allocation 10MiB cannot be installed because the Subnet’s remaining memory capacity is 0MiB”
Wallet canisters on ic may only be created by an administrator.
Please submit your Principal (“dfx identity get-principal”) in the intake form to have one created for you.

the other error :slightly_smiling_face:
The replica returned an HTTP Error: Http Error: status 413 Payload Too Large, content type “text/plain; charset=UTF-8”, content: Request 0x8feed6ad5cdcd7f7a50cee13c453931dfbe14518624be37b24ae31dcf0feccf4 is too large.

more bug , linkedup_assets dependencies canister A ,A dependencies B ,dfx build --all is ok,but single exec dfx build linkedup_assets case error alias B not found

If you’re running dfx build on individual canisters that have dependencies, you’ll need to declare the dependency canisters in your dfx.json, similar to this: Development workflow: quickly test code modifications - #9 by Ori

Please try using 0.7.0-beta.3:
DFX_VERSION=0.7.0-beta.3 sh -ci "$(curl -fsSL https://sdk.dfinity.org/install.sh )"

1 Like

when import Deque into HashMap
var hashMap = HashMap.HashMap<UserId, Deque>(1, isEq, Principal.hash);
Stderr:
/Users/libaozhong/dfinitly/my_rust_program/linkedup/src/linkedup/database.mo:93.47-93.52: type error [M0029], unbound type Deque

It seems to indicate that the Deque data structure cannot be found in your code.
try:

import Deque "mo:base/Deque";

var hashMap = HashMap.HashMap<UserId, Deque.Deque<T>>(1, isEq, Principal.hash);

when after upgrade dfx version to 0.7.0-beta.3 , import linkedup_assets from “ic:canisters/linkedup_assets” in .js file exec trigger undefine exception,

DFX_VERSION=0.7.0-beta.3 sh
libaozhongdeMacBook-Pro:linkedup libaozhong$ dfx ping ic
The replica returned an HTTP Error: Http Error: status 404 Not Found, content type “”, content: Not Found

Have anyone had a same problem?


all canisters are deployed locally
But server refuses connection, DFX is running

Have you tried using “localhost” instead of the loopback IP address to access the page in your browser?

How are you trying to access your front-end canister?
Like this: http://127.0.0.1:8000/?canisterId=ryjl3-tyaaa-aaaaa-aaaba-cai ?
Also check the 8000 port is not in use.

Yes buy the recommended method from Frontend tutorial docs.
Port is not in used. This happens with 0.7.3 beta version. As 0.6.26 has issue with canister memory allocation I can’t rebuild frontend there :confused:

пн, 26 апр. 2021 г., 13:19 Gabriel via Internet Computer Developer Forum <[email protected]>:

both, same error, don’t know why.


here is the clearly says it’s running

a new error now
TransportError