II replica returned an error: 3 "Canister has no update method 'wallet_call'"

I’m on Ubuntu 20.04.2 LTS, dfx 0.8.0, II 0.1.0

The Replica returned an error: code 3, message: “Canister rwlgt-iiaaa-aaaaa-aaaaa-cai has no update method ‘wallet_call’”

This happens when I’m trying to upgrade, reinstall, install, stop, build or deploy canisters.

Canister rwlgt-iiaaa-aaaaa-aaaaa-cai is the internet_identity local canister.

The structure of my workspace is as follow:

  • internet_identity
  • myProject

and I’m running dfx start --clean --background from internet_identity directory (port 8000) + II_ENV=development dfx deploy --no-wallet --argument ‘(null)’.

After that try to do the above commands but throws the error.

Thanks in advance.

Solved!! Stop everything and delete the .dfx directories on both internet_identity and myProject dir and voilà.


Did you need to deploy again after deleting?

Yes, you should dfx start and then dfx deploy.

1 Like

Can you explain more what you mean by deleting the .dfx directories?

1 Like

Of course. In the image you can see the .dfx directory, just delete it.



Thank you, Do you have any clue about this? I am sorry about disturb you at this time

I did try that, they used to connect with GitHub which is easier to do, but they no longer do with Github, they switched to Twitter, I have no clue how to do that. Thank you for the help!

Try checking if you are a controller on that canister! If not you have to authorize yourself first.

If that doesn’t work consider:

Maybe you don’t have enough cycles to deploy (Or don’t have a wallet canister).

Try dfx wallet --network ic balance and you will probably receive the same error.

Check this to get your Faucet cycles. Just authenticate with your twitter account.

If you already ask for them or can’t comply with the requirements follow this.

And don’t worry, good luck there