Seed Round Access

at this point it looks like dfinity is just f*** with seed investors…what do we get after 4 years?

  • Another 4 years of linear vesting, announced a few hours before token launch
  • Buggy and incomplete docs and a (mandatory) KYC that’s not working
  • Support is practically non-existent
  • No hardware wallet support (well not even ANY wallet)

I can confirm the KYC issue was fixed for me.


4 years and 200 employees.

I can also confirm that there is no email confirmation. Will we be notified by email when the KYC is complete? And how long can we expect this to take?

I also have same issue

I got through the KYC and it said it was being processed but no confirmation email or anything… jeez

1 Like

Ok so I got to KYC stage, but when i submit the form it fails saying:

“please enter your date of birth”

which i am of course already doing (in the format specified)

how can i proceed?

I suggest to try a different browser as a quick solution. Could be causing the issue.

This. It’s embarrassingly bad.I won’t even go into all the problems other than say I still can’t KYC.

For a project which wants to be so huge, someone actually needs firing for this utter shambles. That and there’s a total lack of meaningful community support for anyone. I feel very sorry for the devs here.

Dfinity look really poor right now. 4 years and fluffed the basics. Sorry folks, really disappointed right now.

EDIT: Used Safari and it worked better than Chrome, which failed on two different devices multiple times.


We could be mad at developers of the project or maybe we could try to understand what the actual priorities were. And that seems to be the actual R&D of breakthrough tech like Chain Key and other critical components. So… maybe let’s be patient and I’m also sure they don’t exactly love this KYC thing, it’s a neccessary evil and maybe they couldn’t find people inside their org that agreed to do this dirty job instead of more interesting things ;D


Hi everyone.
how come Windows isn’t supported in the claim process? it’s only by far the most popular OS in the world. I mean, people need to go and buy a mac to be able to claim.

Now that that’s out, I need some help. I’m following the instructions to letter (macOs, yes I had to buy two) and when I get to the dfx ping command I’m getting the following error:
A key was rejected by Ring: InvalidEncoding

I’m unable to proceed further. I’ve tried this on two different brand new mac machines (not M1).

help would be appreciated

That’s all fine and well, but the KYC forms should’ve been available days before the launch. Putting additional forced delays onto just a part of contributors is simply unfair and utterly disappointing. If anyone, the seed contributors should’ve been the first ones to have access, not the other way around. I don’t feel that our contributions are being valued. The banks are being valued. This is not the way of crypto.
And it doesn’t matter if someone wants to sell or not, after 4 years everyone should have that right to decide by themselves, and we weren’t granted that. To sell the measly 2% of our tokens.

1 Like

Was the invalid character issue ever resolved? I get that on the $RESULT call.

Edit: Also FWIW, I used two very old laptops and just put clean installs of Ubuntu on them, one with networking, one without. I tend to think linux will be easier and much cheaper than buying Macs for this.

Never found a solution. I was told it’s because of a fundamental format issue if doing offline signing but I can’t confirm that. I’m using a mix of linux and mac devices.

Also, just looking through the notes, there’s no actual instructions for how to do anything once disbursed. On top of that, it looks like to do anything, or at least some things, after a reboot you need to reput in your passphrase so the command line variables work.

I could understand if this was a rushed release, and perhaps it was in the end, but neither this nor the airdrop being held in a (not very good) centralised exchange for 12 months is winning any friends. Oh, or the -still- lack of clarity on token releases.

(once again, not putting this on the devs here - this is an organisational issue)

Someone got tokens released, Coinbase has spot trading going on. The result returned is a hex value that looks like a transaction id (if it were ethereum for example). Is there a block explorer or someway to map that to anything?

Why am I getting this error when trying to install the SDK

Curl:23 failure writing output to destination dfinity-sdk: command failed

I also wonder, since our tokens were pre-aged 18 months if that means 18 of the 49 neurons are vested already

Probably no write permission for the user in the directory

Oh this is farcical.

If you contact support with the issues, as requested across Twitter, Telegram and here - they tell you they can’t help and to use this forum. I just got the email.

Well, any thoughts I had on using dfinity any time soon are rapidly disappearing.


Hi there, thank you for reaching out with this feedback. Unfortunately at the moment many of these systems are highly technical. If you feel you need some help with getting started, we would encourage you to reach out to the Developer Support Forum, where your question may already have been addressed or resolved previously by the community.