Problem: succeed to authorize Macbook Pro as the first device, but fail to authorize Macbook Air as the second one

I have successfully added my Macbook Pro as the first authorized device, but failed to add a Macbook Air as the second authorized device.

Here’s the details:

  1. I have done these:
  • open
  • Already registered but using a new device ?
  • Enter User Number


  1. Then it require me: Use your security key with, but I don’t have a security key.


  1. Then I clicked the backward arrow at upper right, and there’s only one option to verify my identity, which is USB security key. And I stuck here.


Need some help to fix this issue.
Many thanks!

It might depend on how old your second macbook is. If it doesn’t have TouchID then your only option for that computer might be to use a Yubikey security key (The blue one with the key icon on it). If that second macbook does have TouchID, then it needs to be set up first, and then I would think that you would be given an option to touch the TouchID button. Also if you’re using an external monitor with the macbook closed, then TouchID might not be available (Apple created new bluetooth keyboards with touchID on them that come with the new iMacs, but they are not for sale individually yet, but they plan to sell them.)

1 Like

First of all, thank you very much mac. :+1:

The second Macbook is quite old without TouchID, bought at 2015.

Then I tried to set an iPhone 6S (Version 12.0) to be the second authorized device.
When I tried to open with chrome at this iPhone, it’s saying that: “This web browser cannot interact with the Internet Computer securely. Please try new web browser software.”
Then I tried with safari, and it’s staying at this page, keeping loading:

Is this iPhone 6S too old to be the second device too? or is there a way to get it done?

I have a friend that this also happened to. She has an iPhone 10. We discovered that the browser would throw this error until she actually set up FaceID. Once she set up FaceID separately in the iPhone settings then the ic0 apps stopped complaining.

IMO THIS IS A DESIGN FLAW IN THE FRONT END as users could still be able to use a security key like a yubikey even if they did not want to use FaceID or TouchID… potentially even on older devices that don’t even support FaceID and TouchID? @kpeacock

I would make sure to set up TouchID separately and then see if the app starts working.


I’m not currently working on the Identity project, but just a reminder that the Internet Identity repo is open-source!

The team has been focused on the critical path, like restoring access when Safari deletes your certs after clearing cache. That said, if there’s something we’re not getting to as quickly as you like, a well-documented pull request might be the fastest way to see the changes you want get adopted!


Hey @mac,

I succeed to authorized the iPhone 6S to be the second device by updating both the ios and chrome to the latest version.

It seems that there’s 2 key factors for device authorization:

  1. The device should can do a biometrics-like verification.
  2. The supported browser should be latest version.

Finally, many thanks for your help along side! :handshake:

1 Like