Neuron not gaining rewards

I have found that at least one of my early contributor neutrons is not gaining rewards. Its set to dissolve in April 2023 and has been voting and has +20 voting power. When I get full neuron info its says maturity_e8s equivelent =0 , I tried to spawn and it tells me it has no rewards.

I think I’ve sort of solved the issue, or at least understand what happened.
I initially had an error when I tried to spawn a new neuron from one of my seed neurons.

“An error happened during communication with the replica: error sending request for url ( http2 error: protocol error: not a result of an error”

This error seems to have caused the spawned neuron ID to be not recorded, or shown in my terminal window.
I guess the neuron actually got spawned, but for some reason the ID of the spawned neuron was not recorded.This is why it is now has 0 maturity.

I have no idea how I can ever recover the spawned Neuron ID, all the commands I can find for listing Neuron ID’s only show seed neurons only and not new spawned neurons. What I need is a way to find neurons under the control of my principle.

I guess the safe way to proceed is to send all spawned neurons to my nns account instead.

So be warned if you spawn neurons from the command line, there is a chance the new neuron ID will not be recorded.

1 Like