Getting error when i run dfx deploy --playground

getting error when i run dfx deploy --playground
WARN: The default identity is not stored securely. Do not use it to control a lot of cycles/ICP. Create a new identity with `dfx identity new` and use it in mainnet-facing commands with the `--identity` flag WARN: Canister 'repository' has timed out. Deploying: repository Reserving canisters in playground... Reserved canister 'repository' with id z7chj-7qaaa-aaaab-qacbq-cai with the playground. Building canisters... Executing 'scripts/ repository' Building repository in ./backend/repository Finished release [optimized] target(s) in 6.89s Size of repository.wasm: 3.9M candid-extractor not found. Skipping generating repository.did. ic-wasm not found. Skipping shrinking repository. Files for repository are in ./canisters/repository Generating type declarations for canister repository: src/declarations/repository/repository.did.d.ts src/declarations/repository/repository.did.js src/declarations/repository/repository.did Installing canisters... Error: Failed while trying to deploy canisters. Caused by: Failed while trying to deploy canisters. Failed while trying to install all canisters. Failed to install wasm module to canister 'repository'. install failed The replica returned a replica error: reject code CanisterReject, reject message IC0503: Canister ozk6r-tyaaa-aaaab-qab4a-cai trapped explicitly: Panicked at 'called `Result::unwrap()` on an `Err` value: WasmParse("Bad magic number (at offset 0)")',, error code None the line 33 to 49 ```use utils::{
bugs::{AppBug, AppBugs},
AppCall, AppInitArgs, AppVersion, Management,
caller_is_controller, hex_string_with_0x_to_vec, name_to_slug,
types::{CanisterId, CanisterIds, UserId},
wasm::{vec_to_wasm_hash, Blob, WasmHash},

fn init() {}

fn get_states() → UserView {
let user_id = ic_cdk::caller().into();



The bad magic number error that you are getting is related to the playground not accepting gzipped wasms. Are you using gzipped wasms?