Any breaking changes to Custom Domains?

Last night our custom domain 221Bravo.App stopped loading. Nothing has been changed on our end to the DNS or the canister code. The raw URL Internet Computer Loading still works so we know the canister is online.

Anyone got an idea of what’s going on?

Do you mean “it stopped working, now it works again and you want to know why” or do you mean “it stopped working and it still does not work”?

Asking because I’m able to load your site.

That’s a positive. I got a message from a user saying they couldn’t get onto the site - I checked and also had the issue. I’ll try clearing my browser and try again :slight_smile:

1 Like

It does not work on my mobile device though. So it seems to be a network issue but, not sure it’s related to the IC because I can load on both. I’ll forward your question/info just in case.

1 Like

Tried again - Chrome, Firefox and IE all not working :frowning:

Hi, can you be specific about the error?
What does it look like?
Can we see some logs from the console specifically which ip address you are hitting?

I am able to load on my mobile so I suspect an issue with one of the boundary nodes but I need to see the error to confirm.

Hi Raymond thanks for looking at this. I’m not getting any errors in the console. This is a screenshot from firefox. I’m not sure if this helps?


On chrome, cleared cookies/ cache and it’s now showing this error?

Hello @NS01,

It looks like you directly configured the IP addresses as you are using an apex domain ( and can therefore not use a CNAME directly.

Unfortunately, we have decommissioned some boundary nodes and others got a new IP address. This should only affect IPv4 and that’s why I think it works for some clients and doesn’t for others.

To fix the situation, you have to update these IP addresses in your DNS records.

To prevent something from happening again, I would recommend you to simply switch to Cloudflare or another nameserver service that allows to specify CNAME/ALIAS/ANAME records for apex domains. We explained how to do that in the following doc.

Please let me know if you need any help in working it out!

1 Like

I’ll probably run into the same problem because I’ve directly placed multiple IP addresses inside the DNS config. Is there any chance someone could add a guide next to Namecheap and GoDaddy - on how to also set Amazon Route 53? There are way too many options there.

Configuring IPs directly shouldn’t be an option since they change. The developers may not even see that a good portion of their users can’t resolve their domain.

1 Like

Thank you I’ll give that a go :slight_smile:

Hey buddy, thanks for the heads up. I’ve managed to get cloudflare to work. I remember trying this before and getting stuck. This time I did things in a slightly different order.

In the doc (DNS configuration guide | Internet Computer) changing the godaddy name servers is at the end of the process. I had to do this first as they wouldn’t allow me to add two CNAME records.

Process was

  1. Change to cloudflare nameservers
  2. delete all the gumph that go-daddy added.
  3. complete the steps in the ICP guide


1 Like

Glad to hear that it worked! I will update the docs accordingly.

Hey @infu,

you mean we should also explain how to set it up using Route 53? I can look into that and include it with the changes that @NS01 suggested.

1 Like

Yes, a guide for Route 53 would be great. I think it’s pretty popular.

Hello @infu and @NS01

I have just updated the docs and included some instructions on Amazon Route 53. I was a bit surprised to learn that Route 53 doesn’t support any CNAME/ALIAS/ANAME for apex domains (unless you alias to an AWS resource). So if you use Route 53, your best option is to use Cloudflare as your nameserver provider.

Let me know what you think about the changes.