SDK Installation Error

Hi - when executing this command on Ubu 20.04 in VirtualBox:

node --version = v10.19.0
npm --version= 6.14.4

sh -ci “$(curl -fsSL https://sdk.dfinity.org/install.sh)”

I get this error:

warn: Not forcing TLS v1.2, this is potentially less secure
info: Version found: 0.7.1
info: Creating uninstall script in ~/.cache/dfinity
info: uninstall path=/home/renny/.cache/dfinity/uninstall.sh
info: Checking for latest release…
warn: Not forcing TLS v1.2, this is potentially less secure
curl: (23) Failure writing output to destination
dfinity-sdk: command failed: downloader https://sdk.dfinity.org/downloads/dfx/0.7.1/x86_64-linux/dfx-0.7.1.tar.gz /tmp/tmp.Vra0QQWwsM/dfx.tar.gz

Should I create the ~/bin and put it in the $PATH first, before executing the curl command.

Further, this worked fine the 1st time I installed it in my VirtualBox. But something got screwed up, so I deleted that 1st installation from the VirtualBox completely, and now I am re-installing everything from the start. Maybe there is some “key” that is saved from the 1st installation that does not allow a new installation?

–thx, jw

So here is a problem and solution I found.

If you install curl using the “Ubuntu Tool” this results in the error described above.

So you need to uninstall that one, then reinstall curl using the “sudo apt install” command. Then it works properly.

3 Likes

Hi,

Im completely new and just looking for a simple advise. I tried installing the SDK Canister cf. dfinity. org/developers, and now i am looking to uninstall everything.

I have followed the uninstall instructions from dfinity themselves: “~/.cache/dfinity/uninstall.sh” (sdk.dfinity. org/docs/developers-guide/install-upgrade-remove.html#remove).

Everything should be removed, uninstalled, and deleted. However, when checking “dfx” commands (e.g., “dfx help”) in the Terminal i still see dfx commands working. Does this mean that the software has not been effectively removed? Does it mean that my local network is still public and shared with the rest of the public network?

Sorry if this is basic, im completely green at this. Thanks in advance for any replies.

//ND