Peculiar issue 7 years and 365 days neuron

I have this peculiar issue with a neuron where Dissolve Delay is set to |7 years, 365 days| and I cannot increase it to 8 years from the NNS ui. Can it be done through the dfx ?

Im missing some rewards because my Annualized Rewards is 18.0% and should be 18.4% right ?

Same problem here for at least 4-5 month

Hi!

Thanks for mentioning it.

We found the issue and we’ll fix it for the next release of the NNS Dapp.

It should not affect so much the rewards. The issue is that instead of exactly the dissolve delay for 8 years you probably have the dissolve delay of 8 years - some seconds (less than a day).

I’ll keep you posted when the fix is released

Thanks!

3 Likes

wow, really appreciate it,

the dissolve delay bonus is indeed 100, but you know I’ve always considered myself part of 8yearsgang :smile:

Thanks for the fast response, very professional.

2 Likes

Same problem happened to me 2 months ago with SNS neurons as well. So this is a general UI issue.
The temporary solution is: dissolve the neuron for more than 1 day and extend the dissolve delay again.

1 Like

FYI this removes all accumulated age bonus. In the long run this could be costly…

2 Likes

Yes, no thanks :), I prefer to wait for the fix to be able to just increase it without pressing the dissolve button

1 Like

Ok, I also think it’s better to just wait in that case :slight_smile:

Speaking of bugs: what else can be included in them?
For ex: having a neuron merged with other neuron, you can’t longer edit it (when it has a stake and maturity = 0) of its followees. However, editing is still possible to ALL other features like CF, auto-staking, hotkeys, etc.

That’s bug or normal NNS Dapp UI behaviour?

Sounds like a bug. I’ll ping the team

Hi!

We released yesterday, you can try it now.

Please let us know how it went.

1 Like

Hi!

Thanks for reporting. I agree that this looks like a bug.

Do I get it right that you accessed the neuron that has 0 maturity and 0 stake and tried to edit the followees?

Does this neurons with 0 stake appear still in the list of neurons to you?

Why did you want to edit the followees of that neuron if it has 0 stake?

Thanks!

1 Like

Thank you ! No problem here, its work like a sharm !

2 Likes

Yes, I accessed a neuron with a stake and maturity of 0 after merging with another neuron. I didn’t choose it from the list of available ones, but I entered the ID of this neuron in a link window in the search engine while in the settings of another neuron.
I wanted to find and edit it to see if it’s possible to use a nulled neuron as a beacon neuron for the rest of the neurons with stake :slight_smile:
After the merge of neurons, the remaining neurons continue to exist. If they aren’t detached from my principal ID after such an operation, it would be good if they remained fully functional and possible to be reused or, for example, topped up (which I don’t know if it’s possible - I paid X ICP to the account of this previous neuron as part of the test and this no longer increases his stake as before).

So the merging in NNS Dapp causes the transfer of the stake + maturity from one neuron to another, but it doesn’t delete them, and addationally blocks the possibility of re-topping them and changing the followees, right?

Hey, I confirm that the fix works, I could increase the dissolve period of the neuron to 8 years from 7 years and 365 days. Awesome, thanks. Keep up the good work, you are awesome.

2 Likes

Thanks for the details!

You are right, the neuron doesn’t disappear, we just hide it from the list of neurons for a better UX.

We were not supporting the neurons with 0 stake; therefore, it could be that some functionality is not working. But I don’t see why it shouldn’t work. I’ll give it a try, the fix might be straighforward.

On another note, I believe there were talks on garbage collecting neurons with 0 stake. The Governance canister has a limited space for neurons currently, and even though it’s still far to be reached, the team was thinking in starting to remove “unused” neurons.

I’ll reach out to the team so that they communicate properly in the forum.

Thanks!

1 Like

A question regarding topping up the neuron.

Did you top up more than 1 ICP or less? 1 ICP is the minimum stake for a neuron. Topping up less will not work.

I topped up < 1 ICP just to check if it is possible to top-up a neuron after merging its stake with another neuron, after when they reaches stake = 0.
I was surprised that it doesn’t work and it’s still zero because I’ve seen some neurons with a stake below 1 ICP (random neuron example).

I think neurons in ‘Dissolved’ state should completely disappear from the register and become only accounts in ICP Ledger. It would be according to quite uncontroversial to me, but logical and simple due to the following warning, which appears in the IC Dashboard with each dissolved neuron in this state from the very beginning.

I believe it’s possible to top up a neuron after merging, but not with less than 1ICP.

1 ICP is the minimum stake.

Some neurons might go below that but probably because they paid fees for rejected proposals.

Regarding whether neurons should completely disappear or not, that’s another interesting topic.

I’ll share this feedback with the team.

2 Likes