Failed to setup wallet caller

When I tried to execute the command dfx deploy for Unity WebGL sample code, I am getting the following error.
I am very new to the ICP developer environment.

Error: Failed to get wallet canister caller for identity ‘default’ on network ‘local’.
Caused by: Failed to get wallet canister caller for identity ‘default’ on network ‘local’.
Failed to construct wallet canister caller.
The Replica returned an error: code 3, message: “IC0301: Canister rrkah-fqaaa-aaaaa-aaaaq-cai not found”

What command is failing for you? I assume it’s dfx deploy.

Most likely you have some interference between different deployments. If you run dfx stop and then dfx start --background --clean, it will clear any previously saved state. Make sure you’re in the right directory when you run dfx start.

1 Like

I tried this. Still, the error is persistent for this particular example. I created a sample application from scratch which is working fine( Not WebGL).

Cannot reproduce; it works on my machine.

Hmm… The error says that there is a wallet configured for the identity, which should be forgotten when running dfx start with --clean. Are you sure that you’re running dfx start --clean in the same directory as dfx deploy? Another option is to rm .dfx before dfx start --clean in the unity project folder since that info would be saved there.

1 Like

I will try the last command and build again.

have u set up it on a mac system?
I made a slighter Adjustment in dfx version.
The project file has an old version of dfx. I manually changed it to the latest one.

Yes, I’m on an M1 Mac. I just tried with the new/current version of dfx and it works as well for me.

Wow. It’s Worked today. When I used the echo command to change the dfx version the actual problem occurred.
I love ICP blockchain and wanted to introduce this to the XR.

Thanks A lot.

I would like to post a small video on LinkedIn.

2 Likes