GLIBC library issues on Ubuntu 16 with dfx version 0.7.0-beta.4, 5, and 6

I am using Ubuntu 16.04.7 LTS, and I can’t run any dfx commands after installing dfx 0.7.0-beta.4, 0.7.0-beta.5, or 0.7.0-beta.6. 0.7.0-beta.3 works just fine.

I get the following errors:

dfx: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by dfx)
dfx: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.25' not found (required by dfx)

Hey @lastmjs, thanks for the note.

We’ll be unable to release a version of DFX that works without glibc 2.29 in the near term because it’s actually quite a heavy lift.

Have you tried installing glibc >= 2.29? This should be a workaround for you. The current LTS of Ubuntu (20.03) has the right version of glibc.

That sounds good, I haven’t tried yet. I believe Ubuntu 16 just went out of LTS, so I shouldn’t expect it to be supported. Thanks for the update

I just updated my OS and dfx seems to be working, thanks again

1 Like