Failed to fetch response: TypeError: Failed to fetch

My Device(Win10) recently can not browse dapps on ic.
And my other devices(mobile, mac) all work well.

Failed to fetch response: TypeError: Failed to fetch

Is there something wrong with my certificate?

1 Like

Hi @Mulander

I just tried to reproduce this using a Windows 11 machine and everything works fine. Could you please do the following:

  1. See if the problem persists
  2. Check if a hard refresh solves the issue
  3. Post the browser and version that you use

Thanks for reporting the issue.

Thanks for your attention.

The problem is still exist after hard refresh.
I think it might be the accidental installation of security policy software that caused the computer’s security policy or certificate to fail. I have turned off the firewall at this point, but I still can’t access it.
So I’m wondering if the https-based encrypted communication on the ic will depend on certain files stored on the client

My browser versions are the newest:

  • canary | version 107.0.5262.0 canary (x64)
  • brave | version 1.42.97 Chromium: 104.0.5112.102 (x64)

Have you also tried other browsers, i.e. Chrome (stable), Firefox, Edge…?

Is there more log output from the service worker? Could you provide a .har File? This would be very helpful!

Yes. I tried Firefox & Edge with the same response.

& My .har files export by brave

I see that

  • the service worker is making the request correctly
  • your browser reports net::ERR_CONNECTION_CLOSED

This seems to be a client side issue (i.e. a network problem on your side). Unfortunately I cannot help you with that. Maybe try resetting your machine / the network components (e.g. router).

Best of luck!

This could be a firewall issue - has been flagged before for some canisters running phishing websites

@Mulander thank you for this thread! We get lots of reports for this and a lot in the last 24 hours.


I have reset my router with these command.

netsh int ip reset
netsh winsock reset
ipconfig /flushdns

and reset both Windows Security & Network & internet.
:rofl: Still not work. Maybe the last solution is reinstall the system.
Anyway, thanks for your help.

Probably. I can’t visit but
And for backends-api-call in dapps(nft market), they’re set to access no raw type

Same with me. I get the same error on my chrome and firefox. OS is Windows 10 Pro. Raw link works but not the actual one. Any pointers?

Error logs

I tried a lot but not worked.
Reinstall the system just solved. :joy:

This is an intermittent issue. It suddenly started working on my system and now its again not working. I am curious about what is wrong.


Is there any fix for the Failed to Fetch error on the NNS and dapps authenticating using the Internet Identity?
I’ve tried multiple network connections, router reset, different browsers, disable firewall, etc, like in previous posts. Mobile access to NNS is fine, just laptop running windows is the issue. Does this require a system reinstall?

Hey just wanted to say that I noticed your message but I don’t really know what to answer is because I and my colleagues are not able to reproduce the issue. So I escalated it a bit further to another team to check if they have an idea.

That said, have you try to access NNS on your windows laptop with your mobile as hotspot? Just asking to rule out a network issue but maybe both your windows device and mobile phone are using same network?

Thanks for acknowledging. Yes - Other devices are able to authenticate without issue via the same network. It’s probably something to do with the firewall. I’ll figure it out - hopefully not a system reinstall. Good evening

1 Like

Thanks for the feedback. I hope it is such an issue and you will find the solution soon then, good luck :crossed_fingers:

Has this issue ever been root caused?

I am also currently experiencing it. I get this error on and but not on And I get the error in Chrome and Brave but not in Safari. Tried system restart etc. but that didn’t help.

Can you provide the stacktrace ? As you mention Chromium, might be a known issue.