error[E0463] when trying to run internet-identity

I’m trying to run internet identity locally. I’m following the steps in the docs, but when I run II_ENV=development dfx deploy --no-wallet --argument '(null)' it fails with error[E0463]: can't find crate for core``

Is there a known issue here? How do I overcome this?

Did you install rust and add the wasm target with rustup?

try: rustup target add wasm32-unknown-unknown before deploy

2 Likes

Yes, I ran that and it returns info: component 'rust-std' for target 'wasm32-unknown-unknown' is up to date

So it doesn’t fix the error[E0463]: can't find crate for core

Yes, I did that but still getting the error.

When running rustc --explain E0463 it seems as though there might be an issue with some crates. Check out the explanation below:

`A plugin/crate was declared but cannot be found.

Erroneous code example:

#![feature(plugin)]
#![plugin(cookie_monster)] // error: can't find crate for `cookie_monster`
extern crate cake_is_a_lie; // error: can't find crate for `cake_is_a_lie``

Maybe you should change to nightly first: rustup default nightly then add the wasm32

Ok, the issue seems to have been fixed by deleting rust and reinstalling.

I did run into another error due to not having make installed on my machine. I did not see this in the list of required dependencies, but it would be helpful to have it there.

Thank you for your help!