Dfx WARN: You seem to be running an outdated version of dfx. But I have latest version installed 0.12.1

When I try to deploy the project it hangs on “building frontend…”

Anyone else had this issue?

Did you try the command “dfx upgrade”? I believe dfx is at 0.13.* range now (but I could be wrong, need to verify).

I have tried to upgrade and was told was at latest version. I also reinstalled with same result. I am using manjaro if that helps.

1 Like

Ok let me psss this to the sdk team. Sorry I couldn’t be more helpful. I’m sure they’ll be able to help.

1 Like

Thanks for your help!

1 Like

Can you try the solution I suggested here?

I tried the solution you offered.
So just “dfx new one” and got this:

Changed the package.json file. “generate”: “dfx --identity anonymous generate one_backend”
and got this:

That sounds like you didn’t start your local replica. dfx start --clean --background should do the trick. If you follow these steps you should be up and running in a few minutes.

So dfx was running.
Not sure if this is helpful or not but I “dfx stop” and started again with: “dfx start --clean --background”:

then tried to deploy again:

dfx start fails? I haven’t seen that happen in a long time, especially with --clean. Let’s try manually cleaning up any state that’s left over.

  1. dfx stop in case anything is still running
  2. dfx start -vvvv to start with debug output
  3. cancel the running dfx start (Ctrl+C)
  4. In the output from dfx start -vvvv you should see a line that starts with data directory: that points to a folder. In my case it is /Users/<user name>/Library/Application Support/org.dfinity.dfx/network/local
  5. rm -rf <folder you found in step 4>
  6. start the replica again (dfx start --clean, with or without --background, as you prefer)
  7. try deploying again

Thank you. That worked. I could have had relics from the past still around as I have upgraded and reinstalled a few times now :slight_smile: