Cannot upgrade dfx to 0.10.0: unable to gunzip file

I’m trying to upgrade dfx from 0.9.3 to 0.10.0, and I’m getting the following error:

> dfx upgrade
Current version: 0.9.3
Fetching manifest https://sdk.dfinity.org/manifest.json
New version available: 0.10.0
Error: Invalid data: unable to gunzip file: Unexpected GZIP ID: value=[60, 63], expected=[31, 139]

dfx upgrade is broken at the moment. There is a workaround wish I not tested posted there :point_right: Dfx 0.10.0 is promoted - #3 by Severin

1 Like