Anyone updated their Plug wallet to version v0.5.3 or later?

Since v0.5.3 Plug allowed changing the network in a way similar to how Metamask handles networks. I tried to update my Plug wallet to the latest version, v0.5.4.1 and my code runs fine but where the Plug modal pops up and I confirm the transaction there an error saying “Failed to verify certificate”.

Source: GitHub - LiveDuo/plug-html-example

1 Like

stuck on same issue, did you manage to get through this?

I haven’t. I’m starting to think now it’s a bug with Plug wallet but I haven’t found any examples with the local replica so I’m not sure what I’m doing is right.

Also opened an issue here "Failed to verify certificate" using a local replica · Issue #594 · Psychedelic/plug · GitHub.

I think you need to call fetchRootKey() for local development: Internet Computer Content Validation Bootstrap

I’ve been using fetchRootKey() from window.ic.plug with no luck. Here’s an example plug-html-example/index.html at master · LiveDuo/plug-html-example · GitHub.

Does it make sense to call fetchRootKey() method from @dfinity/agent even when using plug wallet?

@LiveDuo I would try calling it before requestConnect or any other calls.

@paulyoung I dig more into it today. It seems that even calling it before requestConnect() didn’t work.

Also calling fetchRootKey() before requestConnect() returns the same root key as if you do the following:

const agent = new HttpAgent({ host: '' })
const rootKey = await agent.fetchRootKey()

Which seems to be the “mainnet” root key.

The screenshot is from this code plug-html-example/App.js at master · LiveDuo/plug-html-example · GitHub.

I have the same issue. Did anyone manage to solve it?

@LiveDuo Hi we have worked on this issue during this release and it should be part of version 0.6

They are working on it.

1 Like