Add NNS root to canister fails

When running

dfx sns prepare-canisters add-nns-root bboqb-jiaaa-aaaal-qb6ea-cai

(The backend of OpenFPL)

I get:

How do I specify that I want to add the nns root on the mainnet as passing the --network=ic flag doesn’t work

Are you using the SNS testing repo to test your canisters? This is only available locally.

If you are looking to test on mainnet, check out the documentation on how to test on mainnet by doing an SNS testflight.

I have been using the sns testing repo.

I am trying to run this command on the live canister:

I just want to know why it fails as I can use that information to ensure dfx sns propose works without the same error, allowing me to confirm the sale will begin and plan around that.

As for the testflight deploy I’ve tried multiple times, this command doesn’t work:

so I get I need to installl sns-cli, which is different from the dfx sns library that contains the canister imports.

Have you considered the response in this post that highlights issues with the sns testflight testing:

Have these been resolved now?

Hey @jamesbeadle. I updated the instructions in my post. The new instructions I’ve tested to work for mainnet deployments.

1 Like

Hi Jennifer,

When you say the command only works locally, it is in the docs under the launch section:

So it should run on --network ic too?


Thank you for the clarification that you are not doing a test flight. Let me check and get back to you.