Why can not create a new Canister?

I tried to create a new Canister on NNS app.
When I process to convert ICP to cycles, it failed.
It says “Error-,28582, No subnets in which to create a canister”, however, there were no step let me choose a subnet.

So what should I do now?


Hi Becky, we appreciate your readiness to get started, but we’re still configuring the application subnets. The pinned post gets into it, but TLDR Mercury should be up to full functionality next week

Thank you for prompt reply!

I want to exchange 0.03 ICP to Cycles, so every transaction with governance canister need 0.0001 ICP as fee?
and if failded, it will return 0.0295 ICP, so 0.0005 ICP may be the punishment or something else?

@flyq This is a great question, and one that’s outside my expertise. Could you create a new post about it so another team member can find your question more easily?


How is the subnet progressing? When can we creat a canister?We want to deploy dapps on ICP network.


What’s the status of this issue? I’m having the same problem as the OP. I’m on dfx 0.6.26

Same issue here! I am on dfx 0.7.0. Tried to deploy first app in IC today using this guide → Network deployment :: Internet Computer But could not deploy because no subnets. @kpeacock

Still waiting to be able to Create Canister

Problem is solved! I just converted cycles.

Check the post here, the subnet application is available now.

1 Like