Rosetta question: Dfinity/rosetta-api docker image

Hi, I am a rookie going through the icrp-1 docs. I am failing to build the roesetta docker image on both my local machine and cloud server, with both returning the same error. Clearly I am doing the same thing wrong but I don’t know what.

when running this command:

docker run
–publish 8080:8080

I get this error:

Failed to initialize ledger client: InternalError(false, Details { error_message: Some(“An error happened during communication with the replica: error sending request for url ( error trying to connect: tcp connect error: Cannot assign requested address (os error 99)”), extra_fields: {} })
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace

My question is how to I configure my icp-ledger canister so that I do not get this build error.

Thanks in advanced,
Vafi Technology

1 Like

Hi, can you try with –publish 8081:8081 and make sure those ports are free?

Hi sir, thanks for your response.

I am still getting the same error with different ports

1 Like

Hi, not sure if it helps (the error looks different), but some time ago I had problem with the latest image while older version was working fine (didn’t test it since then) - same behavior on local personal mac and remote linux server:

Thank you for the helpful reply, the older image is working on my machine.

1 Like

There appears to be an issue with the latest rosetta image.

1 Like