Protected Recovery Phrases: Plan and Progress

I think I saw some (pseudo?)code which added this as a boolean value and I would like to suggest that an enum be used instead to protect against boolean blindness.

I would hate for there to be a bug because someone made a programming error where they provided true or false but meant the opposite.

I propose something like this instead:

enum {
  Protected,
  Unprotected,
}

I’m not sure if this has any impact on the size concerns.

2 Likes