Nothing is working for me

I have been researching icp and Dfinity for some months and really like the project so I decided to invest and stake. Have left messages on Facebook icp group, no replies. I find links on the pages for information display blank. I have been trying to create an anchor and find through the process I am deterred by Google and DuckDuckGo which disable options on the page and mobile confirmation. I added a Plug Wallet but find little information therefore I have trust issues which seem to be growing overall.

I have a Binance account and they stake for 6 months but I have trust issues with them.

What do I want:
Best cold storage device.
Best place to send coins for staking.

1 Like

Hi there,

I can try to help here.

Did you try the Ic wiki? It has list of options available from across the ecosystem: Acquiring and managing ICP holdings - Internet Computer Wiki

Fwiw I don’t think many people in IC community are on FB group. For context, I don’t know anyone on it

  1. For staking options you can see:

  1. For Internet identity tutorial you can see:

Let me know if this doesn’t work for you. I hope that helps.

If something is unclear let us know so we can update the wiki

Curious about this. Can you please tell me which links are blank. Need to fix this ASAP so I can ask around. Not good at all.

Hmmm. This sounds like a missconfigured browser extension TBH. Can you confirm what browser are you using, and what extensions if any? I use ublock origin for example, and I don’t have any options on the page disabled. I can’t see how google or ddg would disable options on the page either, so that’s why my hunch goes towards a bad extension.

Could you try in a clean browser and report back? Also, it would help to provide as much information as possible about what steps you’re taking, what tutorial or document you’re following, etc. It can help people help you faster. Good luck!

1 Like

Thank you diegop, I have been using this page and is where I found my problems with trying the 4 steps to acquiring staking. Also the Acquiring managing ICP holdings and ICP custody options links does nothing but send you back to the Wiki.

I tried the Internet Identity App, Clicking on Create an Internet Anchor I add a Device Name which I then receive a dropdown with 3 selections. I don’t have a External Security key or built in sensor or Add a new Android phone and select the third option which sends a message to my mobile Verify your identity which does nothing but time out no matter how many times I tap it but it does allow me to cancel.

If I buy a Ledger Nano I feel I will have the same problems with adding a anchor and still have no staking. gives nothing more than a blank page with Body does not pass verification**

I will not bother with Facebook.

1 Like

I have installed UBlock and will need some time to understand and use this extension. So I will get back to you.

I also have Plug but is still in Alpha and I can’t find much information about them, not sure if they will be around in the future with my savings. Do you have any more info on them as they are recommended by DFinty?

I have several hundred icp sitting in my Exchange which does not provide staking services bit I do have Binace but from the reviews I am not keen to use their services which are restrictive in staking. I have coinbase as well and can’t find staking and don’t have payments system in my country…

This is Helpful.

Ok I will be away next few days but I don’t want to block you. Let me ping someone in the team to see if they can find ways to unblock you.

Thanks for the helps diegop

From what I understand you’ve only attempted to create a new identity anchor from your desktop and are running into issues when trying to complete the anchor identity creation process.

Have you tried to create a new identity anchor directly from your mobile device?

Thanks for the help, I have tried on my mobile with the same outcome. Would getting a Yubico key - USB port for the desktop with NFC for my mobile be any help or is there a better key.