Issue with Psychedelic package installation

I’m having difficulties installing the packages from the Psychedelic npm repository.
I followed along the instructions on Getting Started - Documentation | DAB to setup the access to the packages. Step 0 works well and I can login to npm and the respective registry. But when I run step 1 to install the package with “npm install @psychedelic/[email protected]”, I get the error code E404 with the attached message.

Did anybody encounter this as well or knows what might be the issue here?

The content of the error log is shown below.

0 verbose cli [
0 verbose cli   '/home/ubuntu/.nvm/versions/node/v16.13.0/bin/node',
0 verbose cli   '/home/ubuntu/.nvm/versions/node/v16.13.0/bin/npm',
0 verbose cli   'install',
0 verbose cli   '@psychedelic/[email protected]'
0 verbose cli ]
1 info using [email protected]
2 info using [email protected]
3 timing npm:load:whichnode Completed in 1ms
4 timing config:load:defaults Completed in 0ms
5 timing config:load:file:/home/ubuntu/.nvm/versions/node/v16.13.0/lib/node_modules/npm/npmrc Completed in 1ms
6 timing config:load:builtin Completed in 2ms
7 timing config:load:cli Completed in 2ms
8 timing config:load:env Completed in 1ms
9 timing config:load:project Completed in 0ms
10 timing config:load:file:/home/ubuntu/.npmrc Completed in 1ms
11 timing config:load:user Completed in 1ms
12 timing config:load:file:/home/ubuntu/.nvm/versions/node/v16.13.0/etc/npmrc Completed in 0ms
13 timing config:load:global Completed in 0ms
14 timing config:load:validate Completed in 0ms
15 timing config:load:credentials Completed in 1ms
16 timing config:load:setEnvs Completed in 0ms
17 timing config:load Completed in 8ms
18 timing npm:load:configload Completed in 8ms
19 timing npm:load:setTitle Completed in 0ms
20 timing npm:load:setupLog Completed in 1ms
21 timing config:load:flatten Completed in 1ms
22 timing npm:load:cleanupLog Completed in 1ms
23 timing npm:load:configScope Completed in 0ms
24 timing npm:load:projectScope Completed in 1ms
25 timing npm:load Completed in 14ms
26 timing arborist:ctor Completed in 3ms
27 timing idealTree:init Completed in 74ms
28 timing arborist:ctor Completed in 0ms
29 http fetch GET 404 https://registry.npmjs.org/@psychedelic%2fdab-js 107ms (cache skip)
30 http fetch GET 404 https://registry.npmjs.org/@psychedelic%2fdab-js 24ms (cache skip)
31 timing idealTree Completed in 209ms
32 timing command:install Completed in 219ms
33 verbose stack HttpErrorGeneral: 404 Not Found - GET https://registry.npmjs.org/@psychedelic%2fdab-js - Not found
33 verbose stack     at /home/ubuntu/.nvm/versions/node/v16.13.0/lib/node_modules/npm/node_modules/npm-registry-fetch/check-response.js:95:15
33 verbose stack     at processTicksAndRejections (node:internal/process/task_queues:96:5)
33 verbose stack     at async Arborist.[retrieveSpecName] (/home/ubuntu/.nvm/versions/node/v16.13.0/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/arborist/build-ideal-tree.js:532:18)
33 verbose stack     at async /home/ubuntu/.nvm/versions/node/v16.13.0/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/arborist/build-ideal-tree.js:503:20
33 verbose stack     at async Promise.all (index 0)
33 verbose stack     at async Arborist.[applyUserRequestsToNode] (/home/ubuntu/.nvm/versions/node/v16.13.0/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/arborist/build-ideal-tree.js:471:7)
33 verbose stack     at async Arborist.[applyUserRequests] (/home/ubuntu/.nvm/versions/node/v16.13.0/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/arborist/build-ideal-tree.js:408:7)
33 verbose stack     at async Arborist.buildIdealTree (/home/ubuntu/.nvm/versions/node/v16.13.0/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/arborist/build-ideal-tree.js:215:7)
33 verbose stack     at async Promise.all (index 1)
33 verbose stack     at async Arborist.reify (/home/ubuntu/.nvm/versions/node/v16.13.0/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/arborist/reify.js:149:5)
34 verbose statusCode 404
35 verbose pkgid @psychedelic/[email protected]
36 verbose cwd /home/ubuntu
37 verbose Linux 5.10.60.1-microsoft-standard-WSL2
38 verbose argv "/home/ubuntu/.nvm/versions/node/v16.13.0/bin/node" "/home/ubuntu/.nvm/versions/node/v16.13.0/bin/npm" "install" "@psychedelic/[email protected]"
39 verbose node v16.13.0
40 verbose npm  v8.1.0
41 error code E404
42 error 404 Not Found - GET https://registry.npmjs.org/@psychedelic%2fdab-js - Not found
43 error 404
44 error 404 '@psychedelic/[email protected]' is not in this registry.
45 error 404 You should bug the author to publish it (or use the name yourself!)
46 error 404 Note that you can also install from a
47 error 404 tarball, folder, http url, or git url.
48 verbose exit 1
1 Like

Solved it.
Had to add the line @psychedelic:registry=https://npm.pkg.github.com/ to ~/.npmrc.