Issue error xtended-numbers in mops

I’m stuck with an issue and could really use some help. I’m working on a project and I need the xtended-numbers package. I added it to my mops.toml file like this:

xtended-numbers = "0.2.1"

Then I ran mops install to get the package. But when I run dfx deploy I’m getting erros like .mops/serde@2.3.0/src/CBOR/ import error [M0009], file ".mops/xtended-numbers@0.2.1/src/NatX/" does not exist .mops/serde@2.3.0/src/CBOR/ import error [M0009], file ".mops/xtended-numbers@0.2.1/src/FloatX/" does not exist

How do I fix the empty directory issue? Any help would be super appreciated! Thanks!

1 Like

Did you encounter any error running mops install?

Is your project’s .mops folder empty?

What the output of this command?

ls $(mops cache show)/packages/xtended-numbers@0.2.1


You can see in my screenshot I already running the command mops install and ls mops packages for xtended-numbers with output not error

and for folder .mops not empty I can see all packages depedency already add in mops here

Try this to clean cache and install:

rm -rf .mops
mops cache clean
mops install
1 Like

Damn cool man thank’s for help, now I already see output error in my canister :blush: