Invalid certificate: Invalid signature from replica signed query: no matching node key found

I couldn’t find this error in the forum search, Google, or the AI, so I am posting it here.
Occurs during local replica development.

Tried moving from 0.15.1 to 0.14.1 but nothing changed.

1 Like

I have no idea, but as you mentioned, you tried to downgrade dfx and assuming you are facing the issue in a frontend app, what version of agent-js are you using? If it’s the brand new version v0.20.0, have you also tried to downgrade the js libs?

1 Like

Thanks, the downgrading of agentjs worked. My library icblast is with dependency * so it doesn’t force you to use any particular agentjs, but if freshly installed gets the latest one - v0.20.0

1 Like

Thanks for the confirmation. I bet the SDK team has published a breaking change but, I forward the question to the team.

“Important note” is probably the reason of this issue: Agent-JS 0.20.0 is released! (replica signed query edition)

1 Like

Sorry - I probably should have held off on the release until the new dfx version was out

dfx 0.15.2-beta.2 has been released. It bundles a recent version of agent-rs and replica and works with the latest agent-js.

Unfortunately, it’s not available with dfx upgrade yet so you’ll have to run

DFX_VERSION=0.15.2-beta.2 sh -ci "$(curl -fsSL"
1 Like

I tried this

   "@dfinity/agent": "0.19.3",
    "@dfinity/auth-client": "^0.20.1",
    "@dfinity/candid": "^0.20.1",
    "@dfinity/identity": "^0.20.1",

but I got

  Plugin: vite:esbuild
  File: /Users/ahmed/Desktop/odoc/src/frontend/data_processing/data_samples.ts
  let error = new Error(`${text}${summary}`);

is it dfinity/agent-js or dfinity/agent? which package? I’m not using dfinity/agent-js but still getting the error

I am getting this error

Uncaught (in promise) Error: Invalid certificate: Invalid signature from replica lfexj-khfra-ys6yv-6cxbx-ms3jg-5ekqu-hxvqa-yj4nh-v5eok-t77q4-jae signed query.
    at _HttpAgent.<anonymous> (index.ts:606:13)
    at _HttpAgent.query (index.ts:535:39)
    at async caller (actor.ts:394:22)
    at async get_initial_data (files.ts:66:25)
    at async App.tsx:29:13

is this compatible with nodejs 20.9 ?

I solved it by deleting node_packages folder and target and upgrade all packages then re-run everything